Bug 70324 - Confusion on the Gnome Menu...
Confusion on the Gnome Menu...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-menus (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-31 12:41 EDT by Johnray Fuller
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-08 17:51:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnray Fuller 2002-07-31 12:41:46 EDT
Hello,

I would like to add the following thoughts to the lively debate over the menu
re-org...

1> "All Applications" should be moved to the top of the menu:

I think the "All Applications" menu-item should be at the top of the menu with a
seperator between it and the rest of the items. This will more cleanly seperate
it from the simplified Gnome Menu.

I am not sure how to clarify the name in a way that tells advanced users to look
here for KDE apps and so forth, but it seems like there is confusion rigtht now
anout this issue.

2> Desktop Switching tool:

Is there a menu item for switching desktops between KDE and Gnome? I can't find
one and I know that switchdesk is no longer a supported app. If there is one, it
should be added to the preferences menu.

3> The "Preferences" menu should indicate its scope in the title:

I think "Preferences" in too vague. It implies global or system settings.
Perhaps "User Preferences" is more appropriate.

Hope this helps!

Johnray
Comment 1 Havoc Pennington 2002-07-31 22:23:54 EDT
1) I agree but I removed All Applications and went with Extras for now, so 
   no longer applies.

2) switchdesk does still get installed by default it seems. I would not put 
   it in the menu though. You can just choose a desktop when you log in... 
   (which is confusing enough, but)

3) I agree the Preferences/System Tools split is a problem, but I don't have 
   a concrete solution to it at the moment. I'm not a huge fan of the word
   "user"...
Comment 2 Johnray Fuller 2002-08-01 10:59:03 EDT
Should the "Extras" menu-item be at the top or bottom of the menu with a
seperator between it to  more cleanly seperate it from the simplified Gnome Menu?
Comment 3 Geert Noel 2002-08-07 15:36:18 EDT
Extras is better than All Applications, but I find the duplicate categories in
the foot menu and Extras still confusing. It seems more logical to have an
Extras (or More, or Other) menu in each category. For example: you would have an
Extras menu at the bottom of the Accessories menu where all extra accessory'ish
applications are. This way you don't have to think whether something is in the
top level menu or the Extras menu: It will always be in the top level category.
I know you will have two levels in each menu this way, but you already have two
levels in the Extras menu anyway.

About Preferences/System Tools: KDE Tools should not be available in the Gnome
environment (but I think this is already fixed in the latest menus). The Server
Settings, Preferences/Control Center, System Tools, etc. could all be available
from 1 central place: you could have a Settings menu with all the Gnome
interface tools (pretty much like Preferences is now) and in this menu you can
have submenus for

System Administration (packages, users, passwords, logs, services, switchers,...)
Device Settings or Hardware Settings (printers, keyboard, soundcard, mouse,...)
Server Settings (apache, samba, nfs,...)
Advanced Desktop Settings (sessions, keyboard shortcuts,... don't know if
screensaver should be in Advanced?)

On a sidenote:

- Move Floppy Formatter, System Monitor, Terminal & CD Writer to Accessories (or
Utilities?)?
- Rename Programming to Development?
- Why isn't Network called HTTP Proxy Settings?
- It would also be nice (don't know if it's possible) to have a nautilus view
where you see all Settings tools on one page, but separated by category (like
OSX, I think).

Anyway, these are just some ideas. Maybe it can help you while tuning the menus
(which is not as easy as it seems ;).
Comment 4 Havoc Pennington 2002-08-07 15:47:25 EDT
I'm convinced Extras is just inherently confusing. The only sane/nonconfusing
thing to do is nuke all the stupid/duplicate apps... sigh. Anyway. 
I hate to clutter the main menus with an Extras submenu in each - in general, 
"submenus bad" - I would like to avoid multiple levels. Multiple levels is more
OK in Extras since you can just ignore Extras entirely...

1 settings menu to me creates lots of submenus, again submenus ugh.


> Move Floppy Formatter, System Monitor, Terminal & CD Writer to Accessories

I think is potentially a pretty good idea.

> - Rename Programming to Development?

"Development" doesn't mean "Programming" for most people. The Programming name
is amazingly enough based on some user testing.

>  - Why isn't Network called HTTP Proxy Settings?

Because if there were other per-user network settings those would be 
in here too, I believe.

> - It would also be nice (don't know if it's possible) to have a nautilus view
> where you see all Settings tools on one page, but separated by category (like
> OSX, I think).

Possible but more of an upstream/gnome.org bug than something I'd really like to
do in a patch...



Comment 5 Geert Noel 2002-08-09 09:13:12 EDT
I guess you're right about the 'evil' Extras menu and the use of submenus. Maybe
you can use some separators in the foot menu to organize the settings and
applications a bit more. There are some items in Extras that can easily be
transferred to the foot menu (eg Gaim and Gftp), and those 'specialised' apps
that most desktop users never use, might as well be dropped from the menu.

You could of course also create an Extras menu that isn't shown by default (or
is that no longer possible in Gnome2?).
Comment 6 Havoc Pennington 2003-01-08 17:51:09 EST
OK, too much stuff in a single bug here. I think most of it is addressed in 
rawhide. I just redid Extras.

Note You need to log in before you can comment on or make changes to this bug.