Bug 70352 - Problem with freshen of openssl-0.9.6-10 rpm
Problem with freshen of openssl-0.9.6-10 rpm
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: openssl096 (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-31 14:57 EDT by Sandi Piazza
Modified: 2007-03-26 23:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-18 12:27:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sandi Piazza 2002-07-31 14:57:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (Windows NT 5.0; U)

Description of problem:
When trying to upgrade openssl-0.9.6-10 to fix the problem reported on 7/29/2002 I get the following:

error: failed dependencies:
        libcrypto.so.0 is needed by cyrus-sasl-1.5.24-6
        libcrypto.so.0 is needed by fetchmail-5.5.0-2
        libcrypto.so.0 is needed by mutt-1.2.5i-3
        libcrypto.so.0 is needed by pine-4.21-23
        libcrypto.so.0 is needed by python-1.5.2-27
        libcrypto.so.0 is needed by samba-2.0.7-21ssl
        libcrypto.so.0 is needed by samba-client-2.0.7-21ssl
        libcrypto.so.0 is needed by samba-common-2.0.7-21ssl
        libcrypto.so.0 is needed by stunnel-3.8-4
        libcrypto.so.0 is needed by imap-4.7c2-12
        libcrypto.so.0 is needed by mod_ssl-2.7.1-3
        libssl.so.0 is needed by fetchmail-5.5.0-2
        libssl.so.0 is needed by mutt-1.2.5i-3
        libssl.so.0 is needed by pine-4.21-23
        libssl.so.0 is needed by python-1.5.2-27
        libssl.so.0 is needed by samba-2.0.7-21ssl
        libssl.so.0 is needed by samba-client-2.0.7-21ssl
        libssl.so.0 is needed by samba-common-2.0.7-21ssl
        libssl.so.0 is needed by stunnel-3.8-4
        libssl.so.0 is needed by imap-4.7c2-12
        libssl.so.0 is needed by mod_ssl-2.7.1-3
 Looking at /usr/lib it appears that there should be a symbolic link created during/after the rpm which will point to the right library.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm -Fvh openssl-0.9.6-10.i386.rpm
2.
3.
	

Actual Results:  I get the errors listed in "Descritpion"

Expected Results:  Install should have performed properly without listing any dependencies on these libraries

Additional info:
Comment 1 Sandi Piazza 2002-08-02 11:31:16 EDT
Thinking that it was going to require that I upgrade all those other rpms, I picked a couple (pine and mutt) and tried to install later versions of them (taken from 
updates.redhat.com) only to be told that there were failed dependencies for libcrypto.so.2 and libssl.so.2 (for pine) and for libcrypto.so.1 and libssl.so.1 (for mutt). If I 
can't update openssl because pine, mutt, etc need the old version and I can't update pine, mutt, etc because they need a newer version of openssl what am I 
supposed to do?!? Thanks.
Comment 2 Alan Cox 2002-12-18 12:27:54 EST
openssl libs arent all back compatible so you need to update the set of affected
packages (eg with up2date). Its a pain.

Note You need to log in before you can comment on or make changes to this bug.