Bug 70353 - can't mount RAID1 partition by label
can't mount RAID1 partition by label
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-31 15:00 EDT by Alexandre Oliva
Modified: 2007-04-18 12:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-14 12:31:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Driver program for the is_raid_partition function (new and improved) (2.41 KB, text/plain)
2002-08-07 18:17 EDT, Elliot Lee
no flags Details

  None (edit)
Description Alexandre Oliva 2002-07-31 15:00:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020722

Description of problem:
A RAID1 device cannot be mounted using its LABEL in /etc/fstab: mount says
there's more than one partition with that label and bails out.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create an ext3 with LABEL=/l on a RAID 1 device with two partitions.
2.Add an entry to /etc/fstab to mount /l from LABEL=/l
3.Try to mount it.

Actual Results:  It will report a failure to mount /l because there is more than
one partition with such a label.

Expected Results:  It should just mount it.

Additional info:

I also had a (non-RAID) partition with label /l/x that might be getting mount
confused.  Even if this is the case, mounting them by label worked on 7.3.

I've verified that the RAID modules are loaded and cat /proc/mdstat shows
/dev/md0 (that contains the /l filesystem) is active.
Comment 1 Elliot Lee 2002-08-07 16:52:27 EDT
Followed instructions exactly, can't reproduce here with util-linux-2.11r-8

Please verify that you really don't have more than one mountable device with the '/l' label.
Comment 2 Alexandre Oliva 2002-08-07 17:08:27 EDT
I do.  All of the RAID 1 components are individually mountable.  I believe this
is why mount gets confused.  I see with strace that mount reads the labels of
all of the RAID component devices when looking for partition labels.  It should
probably skip RAID components when doing this.  Tested with util-linux-2.11r-8
and mount-2.11r-8.
Comment 3 Elliot Lee 2002-08-07 18:17:38 EDT
Created attachment 69404 [details]
Driver program for the is_raid_partition function (new and improved)
Comment 4 Elliot Lee 2002-08-07 18:19:51 EDT
util-linux-2.11r-9 (in beehive/rawhide) has, I think, the fixes for my braindead detection. If it 
doesn't, please let me know.
Comment 5 Alexandre Oliva 2002-08-07 18:28:11 EDT
The driver program has correctly detected all my raid devices, and noticed that
the non-raid ones weren't.  I'll try the new RPMS after they show up in rawhide.
 Thanks for looking into this!
Comment 6 Alexandre Oliva 2002-08-08 08:33:39 EDT
Confirmed fixed in util-linux-2.11r-9.  Now similar code has to be merged into
nash, so that RAID1 root can be properly mounted.  Thanks!
Comment 7 Kambiz Aghaiepour 2002-09-11 17:31:02 EDT
Can you give any indication as to when an errata will be available for 7.2?

Thanks
Kambiz
Comment 8 Elliot Lee 2003-01-14 12:31:24 EST
Not planning on it.

Note You need to log in before you can comment on or make changes to this bug.