Bug 70358 - ps shows very weird memory usage
Summary: ps shows very weird memory usage
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL: http://christian.shacknet.nu/~christi...
Whiteboard:
Keywords:
: 69609 70390 (view as bug list)
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-07-31 19:37 UTC by Christian Karlsen
Modified: 2007-04-18 16:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-13 09:34:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christian Karlsen 2002-07-31 19:37:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020722

Description of problem:
just upgraded to the newest beta release (from redhat 7.3), and 'ps' shows very
abnormal memory usage, neither 'cat /proc/meminfo', 'top' or 'free' shows
abnormal usage so I doubt it's a kernel-issue

Version-Release number of selected component (if applicable):
procps-2.0.7-21

How reproducible:
Always

Steps to Reproduce:
type 'ps aux'

Actual Results:  see URL

Additional info:

kernel 2.4.18-7.80

Comment 1 Peter van Egdom 2002-07-31 21:18:30 UTC
I'm seeing this too (on a freshly installed Red Hat Linux Limbo (beta 2) 7.3.93).


This is the output I'm seeing on Red Hat Linux release 7.3 (Valhalla) :

USER       PID %CPU %MEM   VSZ  RSS TTY      STAT START   TIME COMMAND
root         1  0.0  1.5  1304  472 ?        S    18:10   0:04 init
root         2  0.0  0.0     0    0 ?        SW   18:10   0:00 [keventd]


and this is the output I'm seeing on Red Hat Linux release 7.3.93 (Limbo) :

USER       PID %CPU %MEM   VSZ  RSS TTY      STAT START   TIME COMMAND
root         1  0.0 4112.5 1256 5144576 ?    S    21:21   0:04 init [
root         2  0.0  0.0     0    0 ?        SW   21:21   0:00 [keventd]



Comment 2 Christian Karlsen 2002-08-01 00:01:51 UTC
hmm, after some further researching I noticed it's a kernel issue, I tried with
2.4.19-pre10 and ps shows normal memory usage.

Comment 3 Jeremy Katz 2002-08-01 07:57:20 UTC
cc'ing Arjan so he can confirm/deny it being a kernel issue

Comment 4 Arjan van de Ven 2002-08-01 09:11:58 UTC
it all looks ok to me here..... but I'm using 7.3 top/ps on my laptop (but
limbo2 kernel)

Comment 5 Christian Karlsen 2002-08-01 14:38:41 UTC
I copied 'ps' from my 7.3 box (procps-2.0.7-12), but it still shows weird memory
usage

Comment 6 Dax Kelson 2002-08-04 20:32:37 UTC
limbo2:

The ps command is horribly miscalculating memory usuage, my box right now
has 256MB ram.

ps aux:

USER PID %CPU %MEM VSZ RSS TTY STAT START TIME COMMAND
rpc 492 0.0 2245.9 1400 5734400 ?  S 17:38 0:00 portmap
rpcuser 511 0.0 2316.5 1444 5914624 ?  S 17:38 0:00 rpc.statd
root    568  0.0 2213.8 1380 5652480 ?    S    17:38   0:00 /sbin/cardmgr

How can portmap be using 2000% of my memory?

Comment 7 Alexander Larsson 2002-08-07 11:22:19 UTC
Sounds like it is a kernel issue, I'll take a deeper look.


Comment 8 Alexander Larsson 2002-08-07 16:09:35 UTC
Yes. The rss field in /proc/pid/stat seems to be way off. Assigning to kernel.


Comment 9 Alexander Larsson 2002-08-09 14:45:17 UTC
*** Bug 69609 has been marked as a duplicate of this bug. ***

Comment 10 Alexander Larsson 2002-08-09 15:39:08 UTC
Changing this to blocker, since the dup was a blocker.


Comment 11 Arjan van de Ven 2002-08-13 09:34:02 UTC
Finally got a handle on this one and found a fix, will be in next build

Comment 12 Jay Turner 2002-08-16 04:36:40 UTC
Looks pretty good with kernel-2.4.18-11.

Comment 13 Jay Turner 2002-08-16 04:37:33 UTC
*** Bug 70390 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.