Bug 70361 - relogin to X requried for consolehelper to grant access to a new SCSI scanner
relogin to X requried for consolehelper to grant access to a new SCSI scanner
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: usermode (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-31 15:57 EDT by Eugene Kanter
Modified: 2013-07-02 18:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-07 10:54:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eugene Kanter 2002-07-31 15:57:07 EDT
How Reproducible:

always

Steps to Reproduce:
1. boot system without scanner ever connected.
2. login to X
3. connect scanner
4. open a console window (xterm, konsole, gnome-terminal, etc)
4. su to root.
5. echo scsi-add-single-device X X X X > /proc/scsi/scsi
6. run kudzu, accept new scanner device.
7. exit from root.
8. run xsane.

Actual Results:

xsane says that no scanner is available.

Expected Results:

xsane finds the scanner.

Additional Information:

xsane can not open scanner device as user because consolehelper does not yet
know about it. Relogin to X allows xsane find scanner device.
Comment 1 Jindrich Novy 2005-04-07 10:54:30 EDT
Eugene, I'm just closing out old bugs. Could you please report a new bug if the
issue still persists with some recent release?

Thanks,
Jindrich

Note You need to log in before you can comment on or make changes to this bug.