Bug 70363 - "no screens found": bad XF86Config (HorizSync) for Sony Multiscan 15sf
"no screens found": bad XF86Config (HorizSync) for Sony Multiscan 15sf
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks: 67217 79578
  Show dependency treegraph
 
Reported: 2002-07-31 16:03 EDT by John Reiser
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-24 15:28:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
actual bad /etc/X11/XF86Config produced by anaconda (3.01 KB, text/plain)
2002-07-31 16:05 EDT, John Reiser
no flags Details
good XF86Config-4 from install of RHL 7.3 (3.70 KB, text/plain)
2002-07-31 16:06 EDT, John Reiser
no flags Details
/var/log/XFree86.*.log with "no screens found" (20.59 KB, text/plain)
2002-07-31 16:08 EDT, John Reiser
no flags Details
/var/log/XFree86.*.log after correcting monitor freqs (21.86 KB, text/plain)
2002-07-31 16:10 EDT, John Reiser
no flags Details
output from user-level 'startx' under bad XF86Config (1.34 KB, text/plain)
2002-07-31 16:11 EDT, John Reiser
no flags Details
output of user-level 'startx' with good XF86Config (2.44 KB, text/plain)
2002-07-31 16:11 EDT, John Reiser
no flags Details

  None (edit)
Description John Reiser 2002-07-31 16:03:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529

Description of problem:
The /etc/X11/XF86Config produced by anaconda (2nd limbo beta) interchanged the
HorizSync and VertRefresh figures for manually-specified Sony Multiscan 15sf
monitor, so 'startx' failed with "no screens found" because no Mode Lines matched.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Fresh install 2nd limbo beta, Personal Workstation option.
2. During configuration for X11, manually choose Sony Multiscan 15sf monitor
(Display card is generic Cirrus Logic GD543x with 1MB RAM and no DDC support.)
3. Accept 800x600@16 bits, but change default to text mode login.
	

Actual Results:  firstboot service fails because "no screens found".  [I
specified text login, but firstboot tries X11 anyway.]  User-level 'startx'
fails because "no screens found".

A copy of /etc/X11/XF86Config is attached.  These lines are wrong:
-----
Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
        HorizSync     50.0-120.0
        VertRefresh   31.0-64.0
        Option "dpms"


EndSection
-----
The HorizSync and VertRefresh numbers have been interchanged.




Expected Results:  The corrected entries in the Monitor section are:
-----
        VendorName   "Sony"
        ModelName    "Multiscan 15sf"
        HorizSync     31.0-64.0
        VertRefresh   50.0-120.0
        Option "dpms"
-----


Additional info:

How could this go wrong?  RHL 7.3 had the correct figures for HSync and VRefresh.

If this is some kind of deliberate "coverage test" for the beta (to see if
anybody tries it, notices, and reports), then I consider it to be an extremely
poor choice.  You _can_ fry hardware this way!
Comment 1 John Reiser 2002-07-31 16:05:14 EDT
Created attachment 68065 [details]
actual bad /etc/X11/XF86Config produced by anaconda
Comment 2 John Reiser 2002-07-31 16:06:51 EDT
Created attachment 68066 [details]
good XF86Config-4 from install of RHL 7.3
Comment 3 John Reiser 2002-07-31 16:08:35 EDT
Created attachment 68067 [details]
/var/log/XFree86.*.log with "no screens found"
Comment 4 John Reiser 2002-07-31 16:10:11 EDT
Created attachment 68068 [details]
/var/log/XFree86.*.log after correcting monitor freqs
Comment 5 John Reiser 2002-07-31 16:11:03 EDT
Created attachment 68069 [details]
output from user-level 'startx' under bad XF86Config
Comment 6 John Reiser 2002-07-31 16:11:52 EDT
Created attachment 68070 [details]
output of user-level 'startx' with good XF86Config
Comment 7 John Reiser 2002-07-31 20:31:30 EDT
Boot for install was "linux text" because only 32MB RAM.  [Package Installation
took 3hr 14min for 531 packages/1770MB.  From 'startx' to quiescent Gnome
desktop takes 15 minutes.  RestInPeace, 32MB configurations;
LinuxTerminalServerProject here we come!]
Comment 8 John Reiser 2002-08-01 10:41:31 EDT
It's a transcription error in building /root/anaconda-ks.cfg, which contains:
-----
xconfig --card "Cirrus Logic GD543x" --videoram 1024 --hsync 50.0-120.0 --vsync
31.0-64.0 --resolution 800x600 --depth 16 --defaultdesktop gnome
-----

Please add the Monitor VendorName and Monitor ModelName to the description. 
They really do help documentation and troubleshooting.
Comment 9 Michael Fulbright 2002-08-02 16:00:38 EDT
I have installed Limbo beta 2 and manually picked the Multisync 15sf and the
anaconda-ks.cfg and /etc/X11/XF86Config files both had the correct values.

I'm a bit confused how you ended up in the state you ended up in. Could you
please try it again and verify?
Comment 10 John Reiser 2002-08-02 16:16:14 EDT
OK, I'm willing to try the install again.

But it's a 3.5hour process (only 32MB RAM), so if there's anything particular to
look for, please tell me by 1700 EDT today.
Comment 11 John Reiser 2002-08-03 00:30:58 EDT
It's reproducible.  I re-ran the complete initial install of 2nd limbo beta, and
both /root/anaconda-ks.cfg and /etc/X11/XF86Config have the hsync and vsync
ranges interchanged: claiming a horiz freq of 50.0-120.0 [KHz], and a vert freq
of 31.0-64.0 [Hz].  It should be horiz 31.0-64.0 [KHz], and vert 50-120 [Hz].

Initial boot from install floppy was "linux text".  Probe during boot messages
reported video card "Cirrus Logic GD543x" [which is correct] and monitor "Unable
to probe" [which is expected because there is no DDC support on the card]. 
Anaconda detected low RAM [32MB] and "switched to text mode" even though that's
what I asked for in the first place.

I chose Personal Workstation.  After 3.5 hours, Package Installation finally
finished.  I said No to the boot disk.  Then:
-----
     Video Card Configuration
     Video Card:  Cirrus Logic GD543x
     Video RAM:  1024
-----
which is correct, and I said OK.

Then:
-----
     Monitor Configuration
     Monitor:  Unprobed Monitor
     HSync Rate:  31.5-48.5
     VSync Rate: 50-70
-----
Here I hit <Enter> to Change the Monitor.  Nothing happened within 1 second, so
I hit <Tab>.  Then I waited about 4 or 5 more seconds, and the list of monitors
appeared [cpu is 90MHz PentiumPlain].  I held down <PageDown> to get to the Sony
region, then hit <up-arrow> a few times to go back to Sony Mulitscan 15sf, and
selected it.  The screen now said:
-----
     Monitor Configuration
     Monitor:  Sony Multiscan 15sf
     HSync Rate:  31.0-64.0
     VSync Rate:  50.0-120.0
-----
which is [would be] correct.  I OK'd that.  Then:
-----
     X Customization
     Color Depth:  Hi Color (16 bit)
     Resolution:  800x600
     Default Login:  (*)Graphical   ( )Text
-----
I changed to Text.  Installation soon finished.

At 1st boot after install, I booted to single user mode by editing the kernel
command line in GRUB to append " single".  I looked at /boot/anaconda-ks.cfg and
at /etc/X11/XF86Config using "cat" and "vi".  Both files were incorrect (horiz
and vert ranges were interchanged), just like the first time I did the complete
install.


Comment 12 John Reiser 2002-08-05 13:51:53 EDT
Found it (at least, narrowed considerably).  Using a spare 2.5GB partition on a
new modern fast machine (10 minutes for Package Install), with ATI Rage 128 card
with 32MB [card supports DDC, I think], same Sony Multiscan 15sf monitor
[monitor does not have DDC: "unable to probe" monitor type]:

If I boot directly from CD-ROM and use a Graphical install of Personal
Workstation, and Change monitor type to Sony Multiscan 15sf, then the
frequencies are correct in each of the install display, ananconda-ks.cfg, and
XF86Config.

If I boot from a floppy with boot.img, and enter "linux text", and do a text
mode install of Personal Workstation, and Change monitor type to Sony Multiscan
15sf, then the install display [character based 'newt', I guess?] is correct,
but the anaconda-ks.cfg and XF86Config are both wrong (numerical ranges of horiz
and vert have been swapped).

So it's something about text mode install, possibly even floppy boot.
Comment 13 Michael Fulbright 2002-08-06 15:25:45 EDT
Thanks - it was a typo in the text mode installer.

I've fixed it.

I appreciate you looking into this further!
Comment 14 Mike McLean 2003-01-24 15:28:41 EST
fix verified in Phoebe public beta 2

Note You need to log in before you can comment on or make changes to this bug.