Bug 703732 - After preupgrade from f14 to f15, yum distro-sync fails even with --skip-broken
After preupgrade from f14 to f15, yum distro-sync fails even with --skip-broken
Status: CLOSED DUPLICATE of bug 704020
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-11 04:45 EDT by Yann Droneaud
Modified: 2011-05-12 14:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-12 14:44:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yann Droneaud 2011-05-11 04:45:11 EDT
Description of problem:

I've run preupgrade on f14 to update my system to f15 Beta.

In the preupgrade wiki page http://fedoraproject.org/wiki/PreUpgrade
it is recommanded to run yum distro-sync

But it fails, even when using --skip-broken.


Steps to Reproduce:
1. Install an F14 system
2. Run preupgrade to F15 Beta
3. Once updated, try to run yum distro-sync
  
Actual results:

yum distro-sync --skip-broken failed with following messages:

  Skip-broken could not solve problems
  Erreur : Paquet : gnome-python2-applet-2.32.0-1.fc14.x86_64 (fedora)
               Requiert : libpanel-applet-2.so.0()(64bit)
  ** 6 problèmes RPMDB pré-existants trouvés, la sortie de « yum check » est la suivante :
  1:gnome-applets-2.32.0-3.fc15.x86_64 a des dépendances manquantes de libgweather.so.1()(64bit)
  1:gnome-applets-2.32.0-3.fc15.x86_64 a des dépendances manquantes de libpanel-applet-2.so.0()(64bit)
  1:gnome-applets-2.32.0-3.fc15.x86_64 a des dépendances manquantes de libpanel-applet-3.so.0()(64bit)
  gnome-python2-applet-2.32.0-3.fc14.x86_64 a des dépendances manquantes de libpanel-applet-2.so.0()(64bit)
  ibus-m17n-1.3.2-2.fc14.x86_64 a des dépendances manquantes de libibus.so.2()(64bit)
  libpanelappletmm-2.26.0-2.fc12.x86_64 a des dépendances manquantes de libpanel-applet-2.so.0()(64bit)



Expected results:

yum distro-sync should bring F15 Beta up to date.

Additional info:

I'm using the testing and debuginfo repositories.
Comment 1 Bill Nottingham 2011-05-11 16:35:51 EDT
This should be fixed in a current-ish gnome-panel update.
Comment 2 Adam Williamson 2011-05-12 14:44:47 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 704020 ***

Note You need to log in before you can comment on or make changes to this bug.