Bug 703742 - [Arrandale] Cannot set secondary screen as the only screen
[Arrandale] Cannot set secondary screen as the only screen
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
15
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
[cat:modesetting]
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-11 04:48 EDT by Saggi Mizrahi
Modified: 2015-03-02 00:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 10:41:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the file previously generated by "Displays" app from gnome 3 (711 bytes, text/xml)
2011-05-12 02:56 EDT, cornel panceac
no flags Details
dmesg since boot with kernel arg (123.25 KB, text/plain)
2011-05-15 11:04 EDT, Saggi Mizrahi
no flags Details
Xorg log (59.47 KB, text/plain)
2011-05-15 11:06 EDT, Saggi Mizrahi
no flags Details

  None (edit)
Description Saggi Mizrahi 2011-05-11 04:48:11 EDT
Description of problem:
When I try to configure x11 to only use the screen connected to the vga port and not the built in screen the resolution\refresh rate gets messed up. Using both of them in a dual screen set up works flawlessly.

I have a lenovo T410 laptop and a Samsung SyncMaster 943bm screen.

Version-Release number of selected component (if applicable):


How reproducible:
99% (it worked once)

Steps to Reproduce:
1.start f15
2.open gnome's monitor configuration dialog
3.configure the secondary screen as the only screen
  
Actual results:
Screen says that mode is not supported

Expected results:
Seeing the crisp blue default desktop image of f15

Additional info:

May the force be with you
Comment 1 cornel panceac 2011-05-12 02:53:30 EDT
Thise indeed worked once upon a time, during f15 development. Now, if i disable the laptop's display, both screens turn off and keyboard freezes. If i manage to press keep this configuration before they turn black, rebooting no longer helps. Otherwise, rebooting returns to the default configuration, both displays are active. 

# lspci -nn | grep -i vga
01:00.0 VGA compatible controller [0300]: nVidia Corporation G86M [Quadro NVS 135M] [10de:042b] (rev a1

if, in .config/monitors.xml, i change 

<clone>no</clone> to

<clone>yes</clone>

everything works as expected, i have output only on the external display. i will attach the complete file, "fixed" version :)
Comment 2 cornel panceac 2011-05-12 02:56:29 EDT
Created attachment 498442 [details]
the file previously generated by "Displays" app from gnome 3

later i replaced 'no' with 'yes' in the clone line.
Comment 3 Matěj Cepl 2011-05-12 07:46:18 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please, reporter, add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Saggi Mizrahi 2011-05-15 11:04:22 EDT
Created attachment 499023 [details]
dmesg since boot with kernel arg
Comment 5 Saggi Mizrahi 2011-05-15 11:06:32 EDT
Created attachment 499024 [details]
Xorg log
Comment 6 Saggi Mizrahi 2011-05-15 11:08:33 EDT
I have no /etc/X11/xorg.conf

I also added log markers in dmesg look for "smizrahi" to mark what I did. I did not mark after the screen got unresponsive because I had no screen. I switched again and then logged. I hope this helps.
Comment 7 Fedora End Of Life 2012-08-07 10:42:00 EDT
This message is a notice that Fedora 15 is now at end of life. Fedora
has stopped maintaining and issuing updates for Fedora 15. It is
Fedora's policy to close all bug reports from releases that are no
longer maintained. At this time, all open bugs with a Fedora 'version'
of '15' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we were unable to fix it before Fedora 15 reached end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged to click on
"Clone This Bug" (top right of this page) and open it against that
version of Fedora.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.