Bug 70379 - .la files considered harmful
Summary: .la files considered harmful
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdelibs   
(Show other bugs)
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-31 22:04 UTC by Owen Taylor
Modified: 2007-04-18 16:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-14 09:12:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Owen Taylor 2002-07-31 22:04:20 UTC
E.g., the version of libkdeui.la I have here has:

# Libraries that this one depends upon.
dependency_libs=' -R/usr/lib/qt-3.0.4/lib -R/usr/X11R6/lib
/usr/lib/libkdecore.la -L/usr/lib/qt-3.0.4/lib -L/usr/X11R6/lib -L/usr/lib
-L/usr/lib/gcc-lib/i386-redhat-linux/3.1
-L/usr/lib/gcc-lib/i386-redhat-linux/3.1/../../.. /usr/lib/libDCOP.la -ldl
-lXinerama /usr/lib/libkdefx.la -lstdc++ -lqt-mt -lpng -lz -lXext -lX11 -lresolv
-lSM -lICE -lpthread -lXrender
/usr/lib/gcc-lib/i386-redhat-linux/3.1/libstdc++.la -lm -lc -lgcc_s'

So, you upgrade to qt-3.0.5 and you have to upgrade kdelibs as well.

What we did GTK+ ,GNOME, libstdc++ was simply not put any .la files in the
packages; note that you can only do this when breaking binary compat,
since .la files depending on the library will have explicit references
to the .la file of the library.

Comment 1 Ngo Than 2002-08-02 07:38:55 UTC
oh yes, i rebuild 3.0.2-3 against qt 3.0.5. thanks

Comment 2 Jay Turner 2002-08-28 19:50:03 UTC
Not sure that I quite understand what the fix was here, but I'm still seeing .la
files in the kdelibs-3.0.3-6 package.  Is this fixed, or still in need of some help?

Comment 3 Ngo Than 2004-09-14 09:12:43 UTC
kde needs .la files for loading plugins and are needed.


Note You need to log in before you can comment on or make changes to this bug.