Bug 70381 - man(8) output nearly illegible if TERM=dtterm or TERM=hpterm
man(8) output nearly illegible if TERM=dtterm or TERM=hpterm
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-31 18:42 EDT by Brent Thompson
Modified: 2007-04-18 12:45 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.5m2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-19 12:12:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Editted sysconfig file (95 bytes, text/plain)
2003-01-17 12:39 EST, Peter Reeve
no flags Details

  None (edit)
Description Brent Thompson 2002-07-31 18:42:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; HP-UX B.11.11 9000/785)

Description of problem:
man(8) displays properly if TERM=xterm, but output is really screwed up if
TERM=dtterm or hpterm.  It worked properly in RedHat versions 6.* and 7.*.
(Maybe only the '-' character is bad -- I cannot remember now).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. connect to limbo system using dtterm or hpterm
2. run man(8) with any target page
3.
	

Actual Results:  Wherever there should be a '-' character, instead shows up some
hex character that 
displays as ordinary '-' in xterm, but in hpterm or dtterm it displays as 'a'
with tilde on top and 
spaces front and back.
It turns out there are enough of these characters that the man(8) output is
amazingly difficult to 
comprehend.

Expected Results:  '-' character should display as normal ordinary '-'
character.


Additional info:
Comment 1 Stephen Samuel 2003-01-03 18:48:24 EST
It also seems to happen with kterm and xterm (using the xterm termcap), but 
gnome-terminal with the xterm termcap works OK. 

It appears that someone changed the gnom-terminal escapes and -- instead  of
creating a new termcap name, they just changed the xterm termcap and confused
just about every other xterm clone out there (including xterm).

GUH!
Comment 2 Stephen Samuel 2003-01-03 19:20:24 EST
OK: I take it back: there's some change to man(1) that seems to be compatible 
with gnom-terminal but incompatible with the other terminals.

Both the termcaps and terminfo's for xterm are unchanged between 7.2 and 8.0 
Comment 3 Eido Inoue 2003-01-03 21:24:25 EST
what locale (type "locale") are you running your tests in?
Comment 4 Stephen Samuel 2003-01-03 22:56:33 EST
[samuel@algh1188y43bi samuel]$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE=C
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

Note: Setting 
export LC_ALL=C 
seems to solve the bug, as does 
export LC_ALL="en_US.iso885915"

which appears to be the default under 7.2
or
export LC_ALL="en_US"
which seems to be the setting under 7.3

Comment 5 Peter Reeve 2003-01-17 12:39:08 EST
Created attachment 89425 [details]
Editted sysconfig file

Same problem with rubbish characters when invoking man from a KDE terminal.
Alright on GNOME or a terminal. Using LANG=en_GB.UTF-8. Corrected the problem
by manually editting the configuration file /etc/sysconfig/i18n. Changed
LANG="en_GB.UTF-8" to LANG="en_GB". This get set/reset by the System settings
language tool.
Comment 6 Eido Inoue 2004-02-19 12:12:49 EST
seems to be fixed with the combo of terminfo stuff in curses 5.4 along
with the UTF-8 grokkin man-1.5m2 and i18nized nroff

Note You need to log in before you can comment on or make changes to this bug.