Bug 70384 - 19 MB lastlog, consisting nearly exclusively of nuls
19 MB lastlog, consisting nearly exclusively of nuls
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: distribution (Show other bugs)
limbo
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Jay Turner
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-31 19:07 EDT by Brent Thompson
Modified: 2015-01-07 18:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-12 15:07:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brent Thompson 2002-07-31 19:07:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; HP-UX B.11.11 9000/785)

Description of problem:
I noticed /var/log/lastlog is really large, and contains essentially all
nuls.   No idea why, what happened, etc., just noticed this on my newly
installed 8.0 system and I'd never seen such a thing before.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.  ???
2.
3.
	

Actual Results:  > # ll /var/log/lastlog
> -rw-r--r--    1 root     root     19136220 07-25 11:31 /var/log/lastlog


Additional info:

lastlog content shows genuine login from remote system named 
kanha.hpl.hp.com:

> # ll /var/log/lastlog
> -rw-r--r--    1 root     root     19136220 07-25 11:31 /var/log/lastlog

> # od -c lastlog
> 0000000 033   D   @   =   p   t   s   /   2  \0  \0  \0  \0  \0  \0  \0
> 0000020  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0
> 0000040  \0  \0  \0  \0   k   a   n   h   a   .   h   p   l   .   h   p
> 0000060   .   c   o   m  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0
> 0000100  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0
> *
> 3015420  \0  \0  \0  \0 331   >   @   =   p   t   s   /   1  \0  \0  \0
> 3015440  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0
> 3015460  \0  \0  \0  \0  \0  \0  \0  \0   k   a   n   h   a   .   h   p
> 3015500   l   .   h   p   .   c   o   m  \0  \0  \0  \0  \0  \0  \0  \0
> 3015520  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0
> *
> 110777320  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0
> 110777334
Comment 1 Elliot Lee 2002-08-23 11:23:24 EDT
lastlog is basically a giant array (indexed by UID) that stores the last login time for each 
user. It's probably not really taking up 19M - use 'du /var/log/lastlog' to find out how much 
disk space this sparse file is using.

In any case, this is not a bug.

Note You need to log in before you can comment on or make changes to this bug.