This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 70385 - pppd connect fails with "--remotename ppp0" in /etc/ppp/peers/ppp0
pppd connect fails with "--remotename ppp0" in /etc/ppp/peers/ppp0
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: initscripts (Show other bugs)
limbo
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-31 19:08 EDT by tom georgoulias
Modified: 2014-03-16 22:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-01 10:26:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description tom georgoulias 2002-07-31 19:08:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
Cannot activate ppp0 device through neat when "--remotename ppp0" is in the file
/etc/ppp/peers/ppp0 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start neat
2. highlight ppp0 device (configured through redhat-config-network-druid)
3. click on activate button.


Actual Results:  Device does not activate, modem will not dial.

Expected Results:  Device should activate, modem will not dial.

Additional info:

/var/log/message excerpt when "--remotename ppp0" is in /etc/ppp/peers/ppp0:

Jul 31 17:45:49 gemini pppd[2109]: pppd 2.4.1 started by root, uid 0
Jul 31 17:45:49 gemini ifup-ppp: pppd started for ppp0 on /dev/ttyS4 at 115200
Jul 31 17:45:49 gemini pppd[2109]: Connect script failed
Jul 31 17:45:50 gemini pppd[2109]: Exit.
Jul 31 17:46:20 gemini pppd[2127]: pppd 2.4.1 started by root, uid 0
Jul 31 17:46:20 gemini pppd[2127]: Connect script failed
Jul 31 17:46:20 gemini ifup-ppp: pppd started for ppp0 on /dev/ttyS4 at 115200
Jul 31 17:46:21 gemini pppd[2127]: Exit.
Jul 31 17:46:51 gemini pppd[2144]: pppd 2.4.1 started by root, uid 0
Jul 31 17:46:51 gemini pppd[2144]: Connect script failed
Jul 31 17:46:51 gemini ifup-ppp: pppd started for ppp0 on /dev/ttyS4 at 115200
Jul 31 17:46:52 gemini pppd[2144]: Exit.
Jul 31 17:47:07 gemini pppd[2188]: pppd 2.4.1 started by root, uid 0
Jul 31 17:47:07 gemini pppd[2188]: Connect script failed
Jul 31 17:47:07 gemini ifup-ppp: pppd started for ppp0 on /dev/ttyS4 at 115200
Jul 31 17:47:08 gemini pppd[2188]: Exit.
Jul 31 17:47:39 gemini pppd[2232]: pppd 2.4.1 started by root, uid 0
Jul 31 17:47:39 gemini pppd[2232]: Connect script failed
Jul 31 17:47:39 gemini ifup-ppp: pppd started for ppp0 on /dev/ttyS4 at 115200
Jul 31 17:47:40 gemini pppd[2232]: Exit.


/var/log/message excerpt when "--remotename ppp0" is NOT in /etc/ppp/peers/ppp0
(working scenario):

Jul 31 17:52:35 gemini pppd[2440]: pppd 2.4.1 started by root, uid 0
Jul 31 17:52:35 gemini wvdial[2455]: WvDial: Internet dialer version 1.53
Jul 31 17:52:35 gemini wvdial[2455]: Initializing modem.
Jul 31 17:52:35 gemini ifup-ppp: pppd started for ppp0 on /dev/ttyS4 at 115200
Jul 31 17:52:35 gemini wvdial[2455]: Sending: ATZ
Jul 31 17:52:35 gemini wvdial[2455]: ATZ
Jul 31 17:52:35 gemini wvdial[2455]: OK
Jul 31 17:52:35 gemini wvdial[2455]: Modem initialized.
Jul 31 17:52:35 gemini wvdial[2455]: Sending: ATDT*70,4857440
Jul 31 17:52:35 gemini wvdial[2455]: Waiting for carrier.
Jul 31 17:52:35 gemini wvdial[2455]: ATDT*70,4857440
Jul 31 17:53:03 gemini wvdial[2455]: CONNECT 44000/ARQ/V90/LAPM/V42BIS
Jul 31 17:53:03 gemini wvdial[2455]: Carrier detected.  Chatmode finished.
Jul 31 17:53:03 gemini pppd[2440]: Serial connection established.
Jul 31 17:53:03 gemini pppd[2440]: Using interface ppp0
Jul 31 17:53:03 gemini pppd[2440]: Connect: ppp0 <--> /dev/ttyS4
Jul 31 17:53:03 gemini /etc/hotplug/net.agent: assuming ppp0 is already up
Jul 31 17:53:05 gemini modprobe: modprobe: Can't locate module ppp-compress-21
Jul 31 17:53:05 gemini modprobe: modprobe: Can't locate module ppp-compress-21
Jul 31 17:53:05 gemini pppd[2440]: local  IP address 199.170.90.46
Jul 31 17:53:05 gemini pppd[2440]: remote IP address 206.224.86.3
Jul 31 17:53:05 gemini pppd[2440]: primary   DNS address 199.170.88.29
Jul 31 17:53:05 gemini pppd[2440]: secondary DNS address 199.170.88.10
Jul 31 17:53:05 gemini su(pam_unix)[2496]: session opened for user root by
(uid=0)Jul 31 17:53:05 gemini su(pam_unix)[2496]: session closed for user root

This line is appears to be added by ifup-ppp, which is the reason I filed the
bug under initscripts.  Please let me know if I have made a mistake or you need
further information.

[root@gemini etc]# rpm -qf /etc/sysconfig/network-scripts/ifup-ppp
initscripts-6.88-1
Comment 1 Thomas Dodd 2002-08-01 10:25:58 EDT
Same here.
Also 7.3.92 initscripts+neat don't handle ppp ONBOOT and demand dialing well. If
usiong demand dialing tools like neat, usernetctl, or ifup don't return untill
there is activity on the interface, like a ping. With the ONBOOT option this
causes init to hang when starting networking.
Comment 2 Bill Nottingham 2002-08-12 15:08:11 EDT
wvdial fixed to re-accept --remotename in 1.53-6.

Note You need to log in before you can comment on or make changes to this bug.