Bug 70386 - RFE: arpwatch option to specify alternative e-mail address
RFE: arpwatch option to specify alternative e-mail address
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: tcpdump (Show other bugs)
1.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Ivana Varekova
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-31 19:27 EDT by Gilbert E. Detillieux
Modified: 2007-03-26 23:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-14 03:21:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to add -e recipient and -s sender options (need to apply arpwatch-drop.patch first) (1.86 KB, patch)
2002-07-31 19:30 EDT, Gilbert E. Detillieux
no flags Details | Diff
Wow! That was quick... Maybe too quick... I've attached a new version of the patch that includes man page updates, usages message update, and the option to disable e-mail sending. (3.27 KB, patch)
2002-08-01 15:36 EDT, Gilbert E. Detillieux
no flags Details | Diff
Third version, also patches arpsnmp for same -e and -s options. (5.27 KB, patch)
2002-08-06 16:34 EDT, Gilbert E. Detillieux
no flags Details | Diff
Patch to correct directory path (/var/arpwatch) in man pages (independent of above). (638 bytes, patch)
2002-08-06 16:40 EDT, Gilbert E. Detillieux
no flags Details | Diff

  None (edit)
Description Gilbert E. Detillieux 2002-07-31 19:27:56 EDT
Description of Problem:
	Arpwatch has hard-coded e-mail addresses, specifically "arpwatch" (a bogus
userid) as the sender, and "root" as the recipient.

Actual Results:
	There's the potential for e-mail delivery problems (though not likely) due to
the bogus sender address.

Expected Results:
	It would be nice to be able to specify alternative addresses, both for the
sender and the recipient.

Additional Information:
	I will attach a simple patch that implements this.
Comment 1 Gilbert E. Detillieux 2002-07-31 19:30:53 EDT
Created attachment 68105 [details]
patch to add -e recipient and -s sender options (need to apply arpwatch-drop.patch first)
Comment 2 Harald Hoyer 2002-08-01 04:57:58 EDT
good thing ... thx !! :)
Comment 3 Harald Hoyer 2002-08-01 07:36:13 EDT
applied in 3.6.3-2
Comment 4 Gilbert E. Detillieux 2002-08-01 15:36:03 EDT
Created attachment 68304 [details]
Wow! That was quick... Maybe too quick... I've attached a new version of the patch that includes man page updates, usages message update, and the option to disable e-mail sending.
Comment 5 Harald Hoyer 2002-08-02 05:28:05 EDT
hey, good work always gets in... thought about bringing this thing in the
official arpwatch upstream on sourceforge?
Comment 6 Gilbert E. Detillieux 2002-08-06 13:45:37 EDT
I had to rework the patch so it can be applied to the pristine source.
Now, where/how do I submit a patch to sourceforge, let alone find where they've
got arpwatch listed there?
(Am I even looking at the right site? sourceforge.net?)
Comment 7 Gilbert E. Detillieux 2002-08-06 16:34:45 EDT
Created attachment 69172 [details]
Third version, also patches arpsnmp for same -e and -s options.
Comment 8 Gilbert E. Detillieux 2002-08-06 16:40:03 EDT
Created attachment 69173 [details]
Patch to correct directory path (/var/arpwatch) in man pages (independent of above).
Comment 9 Leonard den Ottolander 2004-04-08 07:06:48 EDT
So the first patch has been applied.
68105, 68304 and 69172 are different versions of the same patch. It
looks like 68304 has become arpwatch-addr.patch
Also 69173 has been applied to the spec file.

Any chance of updating arpwatch-addr.patch to attachment 69172 [details]?
Otherwise this can be closed ERRATA? or CURRENTRELEASE.
Comment 10 Ivana Varekova 2005-02-14 03:21:18 EST
Thank you for your notice, the patches were applied.
The fixed version is 3.8.2-9.
Ivana Varekova

Note You need to log in before you can comment on or make changes to this bug.