Bug 703886 - Federation bridge doesn't recover from session errors
Federation bridge doesn't recover from session errors
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.3
Unspecified Unspecified
high Severity unspecified
: 3.0
: ---
Assigned To: Ted Ross
Leonid Zhaldybin
: Patch
Depends On:
Blocks: 698367
  Show dependency treegraph
 
Reported: 2011-05-11 10:24 EDT by Andy Goldstein
Modified: 2014-11-09 17:38 EST (History)
5 users (show)

See Also:
Fixed In Version: qpid-cpp-server-0.14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-24 11:02:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Suggested patch (6.73 KB, patch)
2011-07-12 10:03 EDT, Jason Dillaman
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-3352 None None None 2012-11-14 15:23:27 EST

  None (edit)
Description Andy Goldstein 2011-05-11 10:24:18 EDT
Description of problem: When creating a federated route (bridge) to another broker, if the bridge's AMQP session encounters an error (such as a queue reaching its maximum capacity upon delivery), messages stop flowing.


Version-Release number of selected component (if applicable): 1.3


How reproducible: 100%


Steps to Reproduce:
1. Set up federation between 2 brokers
2. Set up a queue in the destination broker to which federated messages will be delivered, and give it a small max message count
3. Send more messages over the bridge than the queue can hold
  
Actual results: the bridge stops pulling messages from the source broker


Expected results: the bridge should attempt to rebuild itself periodically if its underlying session has errors


Additional info: this could possibly be mitigated by using producer flow control in MRG-M 2.0
Comment 1 Jason Dillaman 2011-07-12 10:03:47 EDT
Created attachment 512435 [details]
Suggested patch
Comment 2 Jason Dillaman 2011-07-12 11:55:08 EDT
See https://issues.apache.org/jira/browse/QPID-3352 for details and proposed patch
Comment 3 Ted Ross 2011-07-12 14:30:40 EDT
Fixed upstream in revision 1145706.
Comment 4 Leonid Zhaldybin 2013-08-14 04:37:13 EDT
Tested on RHEL6.4 (both i386 and x86_64). This issue has been fixed.

Packages used for testing:

python-qpid-0.22-4.el6
python-qpid-qmf-0.22-8.el6
qpid-cpp-client-0.22-10.el6
qpid-cpp-client-devel-0.22-10.el6
qpid-cpp-client-devel-docs-0.22-10.el6
qpid-cpp-client-rdma-0.22-10.el6
qpid-cpp-client-ssl-0.22-10.el6
qpid-cpp-server-0.22-10.el6
qpid-cpp-server-devel-0.22-10.el6
qpid-cpp-server-ha-0.22-10.el6
qpid-cpp-server-rdma-0.22-10.el6
qpid-cpp-server-ssl-0.22-10.el6
qpid-cpp-server-store-0.22-10.el6
qpid-cpp-server-xml-0.22-10.el6
qpid-proton-c-0.4-2.2.el6
qpid-qmf-0.22-8.el6
qpid-qmf-devel-0.22-8.el6
qpid-tools-0.22-3.el6

-> VERIFIED
Comment 6 errata-xmlrpc 2014-09-24 11:02:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1296.html

Note You need to log in before you can comment on or make changes to this bug.