This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 704359 - 389-admin-console-1.1.7-2.fc15 cannot be rebuilt on F-15
389-admin-console-1.1.7-2.fc15 cannot be rebuilt on F-15
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: 389-admin-console (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rich Megginson
Fedora Extras Quality Assurance
: screened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-12 17:54 EDT by Karsten Hopp
Modified: 2012-01-09 10:53 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-09 10:53:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2011-05-12 17:54:07 EDT
Description of problem:
The build aborts with an unknown symbol error:


+ ant -Dconsole.location=/usr/share/java -Dbuilt.dir=/builddir/build/BUILD/389-admin-console-1.1.7/built
Buildfile: /builddir/build/BUILD/389-admin-console-1.1.7/build.xml
prepare_build:
    [mkdir] Created dir: /builddir/build/BUILD/389-admin-console-1.1.7/built/classes
import_console:
build:
    [javac] /builddir/build/BUILD/389-admin-console-1.1.7/build.xml:102: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds
    [javac] Compiling 63 source files to /builddir/build/BUILD/389-admin-console-1.1.7/built/classes
    [javac] /builddir/build/BUILD/389-admin-console-1.1.7/src/com/netscape/management/admserv/panel/TurnOnSSL.java:178: cannot find symbol
    [javac] symbol  : constructor CipherPreferenceDialog(<nulltype>,boolean,boolean,boolean,boolean,boolean,boolean)
    [javac] location: class com.netscape.management.client.security.CipherPreferenceDialog
    [javac] 	    CipherPreferenceDialog cipherPref = new CipherPreferenceDialog(null, true, true, true, domestic, false, true);
    [javac] 	                                        ^
    [javac] Note: Some input files use or override a deprecated API.
    [javac] Note: Recompile with -Xlint:deprecation for details.
    [javac] Note: Some input files use unchecked or unsafe operations.
    [javac] Note: Recompile with -Xlint:unchecked for details.
    [javac] 1 error


If there was a API change somewhere, the N-V-Rs of the offending buildrequirements need to be adjusted.

Version-Release number of selected component (if applicable):
389-admin-console-1.1.7-2.fc15



Additional info:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=215991
Comment 1 Vesselin Kolev 2011-05-29 17:10:13 EDT
You have to install idm-console-framework first. The last contains compiled class CipherPreferenceDialog.class (CipherPreferenceDialog is defined there) in /usr/share/java/idm-console-mcc-1.7.7.jar:

com/netscape/management/client/security/CipherPreferenceDialog.class

This problem has been corrected in official Fedora package release (Fedora 15) by adding the correct BuildRequires declaration in the spec file:

BiuldRequires: idm-console-framework

Because Google often points to this page I think it's good idea to add an answer as comment.
Comment 2 Rich Megginson 2011-05-31 10:06:21 EDT
(In reply to comment #1)
> You have to install idm-console-framework first. The last contains compiled
> class CipherPreferenceDialog.class (CipherPreferenceDialog is defined there) in
> /usr/share/java/idm-console-mcc-1.7.7.jar:
> 
> com/netscape/management/client/security/CipherPreferenceDialog.class
> 
> This problem has been corrected in official Fedora package release (Fedora 15)
> by adding the correct BuildRequires declaration in the spec file:
> 
> BiuldRequires: idm-console-framework
> 
> Because Google often points to this page I think it's good idea to add an
> answer as comment.

I don't think that's it.  389-admin-console.spec has always (afaik) had this:
http://pkgs.fedoraproject.org/gitweb/?p=389-admin-console.git;a=blob;f=389-admin-console.spec;h=d901a1fb144c783c8d16fc9c1a8fb82691f68158;hb=refs/heads/f15

BuildRequires: idm-console-framework

I think the build problem was a transient problem caused by a change in the CipherPreferenceDialog API.  The version of idm-console-framework available for builds had not yet been updated to use the new API.

Note You need to log in before you can comment on or make changes to this bug.