Bug 70443 - Bugzilla should support UTF-8 in bug reports
Bugzilla should support UTF-8 in bug reports
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
i386 Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
:
Depends On: 76743
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-01 10:14 EDT by Christian Rose
Modified: 2007-04-18 12:45 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-08 14:55:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 126266 None None None Never

  None (edit)
Description Christian Rose 2002-08-01 10:14:37 EDT
It seems Red Hat Bugzilla doesn't grok non-ASCII characters in bug reports. I
suspect the database backend is the culprit, as all other Bugzillas I know will
handle iso-8859-1 just fine.

This makes creating bug reports regarding i18n a real pain and sometimes the bug
reports very hard to understand since either the characters are displayed
wrongly in the report or the exact characters must be described rather than
shown in the report, which can be a real mess.

It would be great if Bugzilla could accept and use UTF-8 in bug reports.
Comment 1 Petri Koistinen 2002-08-16 19:49:05 EDT
Here is example of problems:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=71702
Comment 2 Petri T. Koistinen 2002-08-31 14:43:16 EDT
Here is another example of problems:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=72541
Comment 3 Petri T. Koistinen 2002-11-01 02:55:51 EST
Is Red Hat working on this?
Comment 4 David Lawrence 2006-04-08 14:04:33 EDT
Red Hat's current Bugzilla version is 2.18. I am moving all older open bugs to
this version. Any bugs against the older versions will need to be verified that
they are still bugs. This will help me also to sort them better.
Comment 5 Aleksey Nogin 2006-04-08 14:55:59 EDT
This WFM now! I just tried typing in some cyrillics (bug 1 comment #53) and it
was processed completely correctly. Even the Bugzilla email came with
"Content-type: text/plain; charset=utf-8" in the header and my UTF-8 comment was
displayed correctly in that email.

Note You need to log in before you can comment on or make changes to this bug.