This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 704488 - pam_access: group names with brackets ()
pam_access: group names with brackets ()
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-13 07:06 EDT by Marcus Moeller
Modified: 2011-05-13 07:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-13 07:14:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marcus Moeller 2011-05-13 07:06:10 EDT
Description of problem:
We are in the situation that some of our group names contain ( and ) signs, e.g.:

mygroup (mydepartment)

Since a recent update, a new feature has been added to pam_access described as follows in the sample configuration:

# The group file is searched only when a name does not match that of the
# logged-in user. Both the user's primary group is matched, as well as
# groups in which users are explicitly listed.
# To avoid problems with accounts, which have the same name as a group,
# you can use brackets around group names '(group)' to differentiate.
# In this case, you should also set the "nodefgroup" option.

which leads to the situation that groups with brackets are not recognised correctly, anymore.
Comment 1 Tomas Mraz 2011-05-13 07:14:55 EDT
Please report the problem to the upstream request tracker:

https://fedorahosted.org/linux-pam/

Although I am very much skeptical of any reasonable resolution for this. I do not think () in group names are portable anyway.
Comment 2 Marcus Moeller 2011-05-13 07:22:49 EDT
done:

https://fedorahosted.org/linux-pam/ticket/2

Note You need to log in before you can comment on or make changes to this bug.