Bug 70473 - Init network script handles ONBOOT='no' not as it should
Init network script handles ONBOOT='no' not as it should
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: initscripts (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-01 12:47 EDT by Jos Vos
Modified: 2014-03-16 22:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-01 12:47:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jos Vos 2002-08-01 12:47:19 EDT
The /etc/rc.d/init.d/network script looks (egrep's) for ONBOOT=no with or
without double quotes, but if you have used *single* quotes, this script does
start ifup for that interface. From a user point of view, it then looks like the
interface is started (which isn't the case because the ifup script honours the
ONBOOT='no' correctly, of course).
Comment 1 Bill Nottingham 2002-08-13 21:52:08 EDT
This should work as of 6.84-1 or later.

Note You need to log in before you can comment on or make changes to this bug.