Bug 70474 - several kickstart directives ignored in interactive ks install
several kickstart directives ignored in interactive ks install
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-01 12:58 EDT by Alexandre Oliva
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 22:45:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2002-08-01 12:58:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020722

Description of problem:
A number of kickstart directives are `forgotten' when the kickstart file
contains the `interactive' directive, so you have to put them in again.  The
ones I've noticed are:

network --bootproto dhcp --hostname free

--hostname free is ignored, and the boot loader screen comes up with `get name
from DHCP'

bootloader --location=partition --md5pass=$1$zLedeO4B$md7uZnrqXfn7dl9zNbaeM0

The advanced bootloader configuration screen comes up with MBR selected (perhaps
a dupe of bug #70380, even though that's for non-interactive kickstart
installs).  The bootloader password comes up disabled.

rootpw --iscrypted <omitted>

The root password comes up empty.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Write a non-interactive kickstart file with the directives above
2.Install, and verify that they've been taken into account (except bootloader
--location=partition)
3.Add `interactive' to the kickstart file.
4.Install again.
	

Actual Results:  A password for root is requested during the interactive
install.  The boot loader password is shown as disabled in the bootloader
screen, even though the password in the kickstart file made it to grub.conf and
anaconda-ks.cfg.  The MBR is overwritten and the boot sector of the /boot
partition is not set up.  Hostname comes up as localhost.localdomain.

Expected Results:  Same as the non-interactive install.

Additional info:
Comment 1 Jeremy Katz 2002-08-02 01:49:02 EDT
Network bootproto one is because we're not allowing the specification of a
static hostname with DHCP right now.

Bootloader location is a dupe.

Passwords don't get filled in because they're crypted and I can't decrypt them,
so there's nothing sensible for me to put in the entry boxes (there's another
deferred bug about this from the 7.2-ish time frame)
Comment 2 Alexandre Oliva 2002-08-02 11:05:18 EDT
> Network bootproto one is because we're not allowing the specification of a
static hostname with DHCP right now.

Err...  Why does it work if done interactively, then?

> Passwords don't get filled in because they're crypted and I can't decrypt them,
so there's nothing sensible for me to put in the entry boxes

The actual password is not displayed anyway, so why not just put in say
`encrypted: <encrypted password>' in the password field?  The user would still
be able to modify it, and the encryption algorithm could recognize this special
pattern.  It might be wise to add characters that can't be entered from the
keyboard to the special pattern, to make sure it's not entered by mistake, as
unlikely as it would be.
Comment 3 Jeremy Katz 2004-10-04 22:45:46 EDT
Not going to do anything with these at this point.  If any of them
still occur and you feel strongly about them, please file again
against a newer release.

Note You need to log in before you can comment on or make changes to this bug.