Bug 70478 - RFE: CD-booted network install should eject CD
RFE: CD-booted network install should eject CD
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
limbo
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
: FutureFeature
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-08-01 13:15 EDT by Alexandre Oliva
Modified: 2007-03-26 23:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-26 13:01:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2002-08-01 13:15:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020722

Description of problem:
It would be nice if an NFS install started by booting the CD with askmethod
would eject the CD as soon as it's no longer necessary.  Currently, the CD is
not ejected at all, so the system ends up rebooting the installer after
installation completes.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot the CD with `askmethod' and, optionally, a kickstart file
2.Choose NFS install
3.Install
	

Actual Results:  CD is never ejected, and after installation is complete, the
installer boots up again unless the CD is removed.

Expected Results:  It should be ejected as soon as it's no longer necessary.

Additional info:
Comment 1 Michael Fulbright 2002-08-02 12:28:14 EDT
Jeremy do we know enough in stage 2 to do this?
Comment 2 Jeremy Katz 2002-08-02 16:10:18 EDT
Unfortunately not.  Also, just ejecting the CD won't do much good since most PCs
will close the CD door on boot and thus the cycle would still be repeated.  

Defer to look at for a future release to see if there's anything we can do
Comment 3 Alexandre Oliva 2002-08-02 16:15:40 EDT
The point was not really about avoiding rebooting into the installer, but rather
about knowing when it is safe to eject the CD to use it for something else. 
Presumably it's just a few seconds after installation starts, and not 30-60
minutes later when it's all done.

Couldn't the installer just check for say root=/dev/cdrom in /proc/cmdline?
Comment 4 Jeremy Katz 2002-08-02 16:33:00 EDT
The root isn't /dev/cdrom so there's no way to tell; as far as the kernel is
concerned, it's a kernel + an initrd from "somewhere", it doesn't care where.
And fwiw, it's safe to remove the CD as soon as the kernel has finished loading.
Comment 5 Alexandre Oliva 2002-08-02 16:38:25 EDT
How about arranging for the CD initrd to eject the CD if askmethod is given in
the command line, then?  Could this hurt in any way?
Comment 6 Alexandre Oliva 2002-08-02 16:38:58 EDT
Erhm...  But this won't help my kickstart case...  Oh, well...
Comment 7 Jeremy Katz 2003-02-26 13:01:42 EST
There's really no way to do this since we don't have any information about how
the machine booted once the kernel starts.

Note You need to log in before you can comment on or make changes to this bug.