This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 704957 - [abrt] blueman-1.21-8.fc15: Functions.py:290:check_single_instance:OSError: [Errno 1] Operation not permitted
[abrt] blueman-1.21-8.fc15: Functions.py:290:check_single_instance:OSError: [...
Status: CLOSED DUPLICATE of bug 760216
Product: Fedora
Classification: Fedora
Component: blueman (Show other bugs)
15
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Juan Manuel Rodriguez
Fedora Extras Quality Assurance
abrt_hash:739a7b2335f65b2ec2af66dd6cc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-16 03:04 EDT by Alexandru Cristian Zanogeanu
Modified: 2012-04-26 16:48 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-26 16:48:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexandru Cristian Zanogeanu 2011-05-16 03:04:35 EDT
abrt version: 2.0.1
architecture:   i686
cmdline:        
component:      blueman
executable:     /usr/bin/blueman-applet
kernel:         2.6.38.3-18.fc15.i686.PAE
os_release:     Fedora release 15 (Lovelock)
package:        blueman-1.21-8.fc15
reason:         Functions.py:290:check_single_instance:OSError: [Errno 1] Operation not permitted
time:           Wed Apr 27 18:57:56 2011
uid:            500
username:       alexandruz

backtrace:
:Functions.py:290:check_single_instance:OSError: [Errno 1] Operation not permitted
:
:Traceback (most recent call last):
:  File "/usr/bin/blueman-applet", line 364, in <module>
:    BluemanApplet()
:  File "/usr/bin/blueman-applet", line 297, in __init__
:    check_single_instance("blueman-applet")
:  File "/usr/lib/python2.7/site-packages/blueman/Functions.py", line 290, in check_single_instance
:    os.kill(pid, signal.SIGUSR1)
:OSError: [Errno 1] Operation not permitted
:
:Local variables in innermost frame:
:isrunning: True
:event_time: 0
:f: <closed file '/tmp/blueman-applet-500', mode 'w' at 0x9d7f968>
:pid: 1899
:id: 'blueman-applet'
:handler: <function handler at 0x9d86374>
:time: 0
:lockfile: '/tmp/blueman-applet-500'
:unhide_func: None
Comment 1 Bruno Martins 2011-06-08 17:34:24 EDT
Package: blueman-1.21-7.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Just booted normal kernel after adding Xen entry to menu.lst.
Comment 2 Horst H. von Brand 2011-09-05 08:35:19 EDT
Package: blueman-1.21-8.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
The machine hanged (vanilla kernel 3.1.0-rc4 with Fedora configuration), hard whut down and reboot gave this.
Comment 3 kalgecin 2011-09-10 03:46:23 EDT
Package: blueman-1.21-7.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
just loged in
Comment 4 kalgecin 2011-09-10 03:47:20 EDT
Package: blueman-1.21-7.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
just loged in
Comment 5 Joshua Martz 2011-10-19 02:36:36 EDT
Package: blueman-1.21-10.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Blueman just crashes when I try to run the applet, as my default user.
Comment 6 Pratyush Sahay 2011-11-14 21:19:13 EST
Package: blueman-1.21-10.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment
-----
System reboot
Comment 7 Sikku 2011-12-08 11:43:21 EST
Package: blueman-1.21-10.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
mmmmmmmmmm
Comment 8 Michael Convey 2011-12-17 10:43:44 EST
I updated my machine (no new packages added) and when I rebooted, I got the error notification. 

rating: (null)
Package: blueman-1.21-10.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)
Comment 9 Jeffrey C. Ollie 2012-01-06 22:24:06 EST
logging in

Package: blueman-1.21-10.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)
Comment 10 Daniel 2012-02-22 03:26:56 EST
crashed right after login

Package: blueman-1.21-10.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)
Comment 11 dalamenona 2012-03-24 05:29:22 EDT
Just booted the laptop, first time it happens

Package: blueman-1.21-10.fc16
OS Release: Fedora release 16 (Verne)
Comment 12 John Cline 2012-03-29 15:09:04 EDT
just failed.  I wasn't doing anything with bluetooth.  It is possible that someone may have been trying to connect to this machine, but I cannot verify that

Package: blueman-1.21-10.fc16
OS Release: Fedora release 16 (Verne)
Comment 13 George 2012-04-26 16:25:50 EDT
All i did was boot up. With usb bluetooth dongle plugged in. tried several. they all do it.

Package: blueman-1.21-10.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)
Comment 14 Christoph Wickert 2012-04-26 16:48:30 EDT

*** This bug has been marked as a duplicate of bug 760216 ***

Note You need to log in before you can comment on or make changes to this bug.