Bug 70503 - updfstab: add config parameter to allow users to mount/umount devices
Summary: updfstab: add config parameter to allow users to mount/umount devices
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kudzu   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-01 20:59 UTC by Jhon H. Caicedo
Modified: 2014-03-17 02:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-31 21:59:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch against kudzu-0.99.63-4, add user access to mount/umount hotplug devices (2.38 KB, patch)
2002-08-01 21:04 UTC, Jhon H. Caicedo
no flags Details | Diff

Description Jhon H. Caicedo 2002-08-01 20:59:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020710

Description of problem:
I found trouble trying to use plugable devices like USB ZIPDrive or digital
cameras while not logged in console, updfstab by default adds a line to fstab
with the option "owner". (I wrote a small patch for this, I will submit them
after this report).

Version-Release number of selected component (if applicable):
0.99.63-4, 0.99.52-1

How reproducible:
Always

Steps to Reproduce:
1.Logout from console...
2.Connect any hotplug device(I use USB Zipdrive250, Sony Cybershot DSC-P30)
3.Get a non console shell to machine. (Network, Serial Terminal)..


Actual Results:  Since no one is logged at the console, the owner of the console is 
"root", so normal users can't mount/umount device.


Expected Results:  Under some circumstances, it would be helpful to give users
rights
to mount/umount hotplug devices.


Additional info:

I have been doing tests with RedHat-7.3 and the rawhide version
of kudzu-0.99.63-4

Comment 1 Jhon H. Caicedo 2002-08-01 21:04:36 UTC
Created attachment 68325 [details]
Patch against kudzu-0.99.63-4, add user access to mount/umount hotplug devices

Comment 2 Steve Lacy 2005-03-11 22:42:19 UTC
I'm having the same problem with my USB removable devices.  I'm
finding that the scsi drivers for cdrom's (sr_mod) will chown the
device such that the "owner" directive in fstab is appropriate, but
that the usb/hdd drivers (sd_mod) don't.  Thus, I can only mount and
unmount from the user interface. 

I really like the patch that Jhon wrote, but it doesn't seem to have
been included in the relase version of Kudzu, since I'm running
1.1.68, and the user directive is not supported.

Comment 3 Bill Nottingham 2005-03-31 21:59:34 UTC
As updfstab is no longer used in current releases (removable media mounting is
done via HAL, fstab-sync, and gnome-volume-manager), changes to updfstab will
almost certainly not be addressed.


Note You need to log in before you can comment on or make changes to this bug.