Bug 70526 - incorrect detection of filesystem type on diskette
incorrect detection of filesystem type on diskette
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: e2fsprogs (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-02 01:21 EDT by Richard Keech
Modified: 2013-07-03 09:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-07 09:47:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Keech 2002-08-02 01:21:56 EDT
Description of Problem:

It is possible to have a the filesystem type of a diskette
be detected as vfat when the last filesystem put on the 
diskette was ext2. 


Version-Release number of selected component (if applicable):

mount-2.11n-12.7.3, kernel-2.4.18-5


How Reproducible:

every time.


Steps to Reproduce:

1. mformat a:

2. mke2fs /dev/fd0

3. mount /mnt/floppy


Actual Results:

floppy mounted as vfat.


Expected Results:

floppy mounted as ext2.


Additional Information:
Comment 1 Elliot Lee 2002-08-07 17:03:52 EDT
The problem is that e2fsprogs doesn't zero out the first block of the device in mke2fs, 
leaving the FAT info there, and mount happens to check for FAT before ext2. It seems that 
the right place to fix it is in e2fsprogs, because leaving the magic stuff there can cause 
problems for other filesystems as well.
Comment 2 Florian La Roche 2002-08-21 15:26:47 EDT
I think this block is kept as it on purpose to leave bootup support in
place.

greetings,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.