Bug 70556 - XEmacs widgets missing
XEmacs widgets missing
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: xemacs (Show other bugs)
1.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-02 10:17 EDT by Ville Skyttä
Modified: 2015-01-07 18:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-02 15:57:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Current situation, without widgets (14.90 KB, image/png)
2002-08-02 10:18 EDT, Ville Skyttä
no flags Details
Configured --with-widgets=athena --with-athena=3d (15.82 KB, image/png)
2002-08-02 10:19 EDT, Ville Skyttä
no flags Details

  None (edit)
Description Ville Skyttä 2002-08-02 10:17:33 EDT
xemacs is currently built without support for any widgets, which disables 
buffer tabs, some customization buttons and dialogs.  Please add 
BuildRequires: Xaw3d-devel and --with-widgets=athena --with-athena=3d to 
%configure.  I'll attach a couple of screenshots.
Comment 1 Ville Skyttä 2002-08-02 10:18:25 EDT
Created attachment 68465 [details]
Current situation, without widgets
Comment 2 Ville Skyttä 2002-08-02 10:19:28 EDT
Created attachment 68466 [details]
Configured --with-widgets=athena --with-athena=3d
Comment 3 Trond Eivind Glomsrxd 2002-08-02 12:04:10 EDT
Xemacs is currently built with "--with-menubars=lucid --with-scrollbars=lucid
--with-dialogs=lucid". Widgets are currently specified as supporting motif only...
Comment 4 Ville Skyttä 2002-08-02 12:55:15 EDT
Well, motif is fine with me too; in that case, add BuildRequires: 
openmotif-devel and configure --with-widgets=motif.  I don't care whether it's 
motif or athena, but widgets are necessary IMO. 
 
BTW; SuSE and Mandrake use the athena approach...
Comment 5 Trond Eivind Glomsrxd 2002-08-02 14:50:00 EDT
Exactly which release do you see a problems with? I don't see any....
Comment 6 Ville Skyttä 2002-08-02 15:57:49 EDT
I've rebuilt the xemacs-21.4.8-10 from Rawhide on a stock 7.3.  When first   
building it, I didn't have openmotif-devel or Xaw3d-devel installed.   
   
ldd /usr/bin/xemacs-21.4.8 for the one from rawhide's   
xemacs-21.4.8-10.i386.rpm reveals that it was compiled with motif support   
(libXm.so.3).  Motif seems to be autodetected...   
   
So, IMO it would be better to explicitly BuildRequire openmotif-devel and   
configure --with-widgets=motif than just to assume it's present.  
  
Oh, and just noticed that there are no widgets in 7.3's xemacs-21.4.6-7, it 
wasn't built with motif support... 
Comment 7 Trond Eivind Glomsrxd 2002-08-07 15:59:09 EDT
Added openmotif-devel as a buildrequires for  xemacs-21.4.8-13

Note You need to log in before you can comment on or make changes to this bug.