Bug 70562 - mozilla spec file has hard set Buildroot:
Summary: mozilla spec file has hard set Buildroot:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: mozilla (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-02 15:05 UTC by Nathan G. Grennan
Modified: 2007-04-18 16:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-20 05:35:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nathan G. Grennan 2002-08-02 15:05:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020712

Description of problem:
I compile almost everything as a user other than root on my sysstem. This idea
seems especially wise after the recent trojaning of a openssh tarball. I do so
with .rpmmarcos and have my rpm building tmp directory set to something other
than /var/tmp because I have set far temp to be a tmpfs. I have run into a
number of rpms that have Buildroot hard set instead of the variables. Please
change the spec file from  "Buildroot:   /var/tmp/mozilla-root" to  "Buildroot:
  %{_tmppath}/%{name}-root" or ideally to "Buildroot:   %{_tmppath}/%{name}".
Then I won't have to forever be modifying the mozilla spec file.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Read mozilla.spec
2.
3.
	

Actual Results:  Buildroot:   /var/tmp/mozilla-root

Expected Results:  Buildroot:   %{_tmppath}/%{name}

Additional info:

Limbo beta2

While I have your attention, why is their an ExclusiveArch of i386 set on
mozilla in the spec file?

Comment 1 Nathan G. Grennan 2003-01-15 12:31:02 UTC
As of mozilla-1.2.1 the Buildroot is still hard set.

Comment 2 Nathan G. Grennan 2004-08-20 05:35:15 UTC
Closing really old bug that I see if now fixed.


Note You need to log in before you can comment on or make changes to this bug.