Bug 70567 - kernel BUG at sched.h:635/do_page_fault()
Summary: kernel BUG at sched.h:635/do_page_fault()
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-02 16:20 UTC by rudi
Modified: 2007-04-18 16:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-02 17:01:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
excerpts from /var/log/messages (24.72 KB, text/plain)
2002-08-02 16:21 UTC, rudi
no flags Details

Description rudi 2002-08-02 16:20:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020801

Description of problem:
When a GNOME session is being started, a kernel BUG will occur. Not
before, not later than that. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Log in from GDM



Actual Results:  All I get is a light blue screen or the splash screen or an
empty desktop - the furthest it got once has been while starting
gnome-panel. X is still working, as the mouse pointer moves with no
problems.

This seems to be reproducible only with kernel versions 2.4.18-7.82
and 2.4.18-7.86. I just tried "ping-pong rebooting" between 7.86 and
7.85. Out of 10-15 boot attempts, with the former the session was
never started successfully. Each time I got a BUG in /var/log/messages.
With the latter the session was successfully started each time;
I only get a dialog that I have verified as being a problem with the
new gnome-session package (and thus irrelevant for this bug).


Expected Results:  I expected the computer to just start the session without
locking up.

Additional info:

I am attaching excerpts from /var/log/messages.

The system is a Dell Latitude C600 (PIII 700MHz) with 128MB RAM and
a R128 Rage Mobility M3. It also suffered from deadlocks in X, which
I have been able to work around by disabling DRI. I am quite
confident now that the DRI deadlocks and this problem (which occurred
also with DRI on) are separate issues. All the packages are updated
to the latest versions in Raw Hide. More information available upon
request.

Comment 1 rudi 2002-08-02 16:21:46 UTC
Created attachment 68504 [details]
excerpts from /var/log/messages

Comment 2 Arjan van de Ven 2002-08-02 16:54:00 UTC
yeah known issue ;(
will be fixed in next build; thanks for the report

/me runs in order to avoid being killed by angry cooworkers :)


Comment 3 Arjan van de Ven 2002-08-02 17:02:08 UTC
woops closing as rawhide


Note You need to log in before you can comment on or make changes to this bug.