Bug 70573 - ftp install fails
ftp install fails
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-08-02 13:07 EDT by Need Real Name
Modified: 2007-04-18 12:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-06 18:57:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-08-02 13:07:18 EDT
Description of Problem:
When installing via ftp from bootnet.img bootable disk, it fails when ftping the
 list of rpms over. It gets all the previous info over, including anaconda, but
fails after you say Desktop install. Console3 has the ftp command line with the
following data:
ftp://!@#$%^&*()!@#$%^&*()tux:/tux1/redhat/limbo. As you can see there's a bunch
of garbage in the ftp line. BTW, tux is my ftp server.

Version-Release number of selected component (if applicable):
limbo, release 2

How Reproducible:
Fails for me every time

Steps to Reproduce:
1. make bootnet disk
2. install from a non anonymous ftp server
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Michael Fulbright 2002-08-02 14:17:08 EDT
I have not seen this issue - could you try with a non-tux ftp server?
Comment 2 Need Real Name 2002-08-02 14:31:28 EDT
Sorry, it is not a tux ftp server, just named that. It is running the standard
ftp server sw, from a 7.2 dist. Sorry for the confusion.
Comment 3 Need Real Name 2002-08-02 14:48:04 EDT
This is from console 3...

Swap attempt of 256M to 512M
IOError socket error occurred getting
ftp://??????????????tux/tux1/redhat/limbo/Redhat/base/hdlist: (-2, 'Name or
service not known')
Comment 4 Peter van Egdom 2002-08-02 20:26:00 EDT
I've been bitten by this bug too. 

A nasty one this is! 

I think it is appropriate to raise the priority of this bug, as it is
quite a showstopper!

Let me start by saying that I did a "linux mediacheck" on all 3 of the
Red Hat Linux 7.3.93 Limbo (beta2) CD's and the status was "PASSED" for
all of them.

OK, now that's out of the way, here's what I did do:


I've got a Red Hat Limbo beta 1 server being both a FTP - and a NFS server.
This is my PII-233/96 MB machine.

I've also got a older machine (P100/32 MB), which I previously used to share
my internet connection. This one had been running 100% with Red Hat 7.3 all
the time.

For testing purposes I decided to upgrade this P100 with Limbo 2. 
But because it has no CD-ROM player I did a network install using FTP.

(FTP server is the PII machine running Limbo 1).
(FTP server daemon on the FTP server = vsftpd)
(I used a non-anonymous ftp session for the installer)

This first thing I did was trying to upgrade the P100 from RH 7.3 to 
Limbo beta 2. I created the bootfloppy with "dd if=bootnet.img of=/dev/fd0"
and put this floppy in the P100.

At first everything seemed alright, the installer looked working nicely,
but when I got to the stage "Reading package information" (a few screens after
the kernel 2.4 swap space configuration screen) of the installer, the PC hung.


I did a <CTRL-ALT-F3> which showed:

 IOError socket error occurred getting ftp://<a couple of unreproducable
 characters>10.0.0.2/home/peterve/CD/RedHat/base/hdlist: (-2, Name or service
  not known')


At first I thought this was an upgrade issue because of the gcc/glib thingy, 
so I decided to do a clean install of Limbo beta 2 on the Pentium100.

So I reboot the P100, put in the flop again and began from scratch this time
by using NFS.

The NFS installations appeared good until +/- 50% of the total process.
The text based installer crashed and said :

 install exited abnormally -- received signal 11
 sending termination signals ..
 sending kill signals ..
 umount procs.
 you may safely reboot system.

I did then a <CTRL>-<ALT>-<F4> and saw :

 <4> Error -3 while decompressing
 <4> c02ccb8a(1031173681)->c1d86000(4096)
 <4> Error -3 while decompressing
 <4> c02c81bb(545656181)->c198a000(4096)
 .. etc ..

This time I wanted to isolate the problem. I have also a HP P3/733 128 MB
which is running Limbo 2. (mainly my test workstation, but I got a NFS
daemon running on this machine).


Ok This time I got my old Red Hat 7.3 install CD's (proven succesfully) and
shared them via the Limbo 2 NFS server (the HP P3/733).

This time I ---> also <--- got a :
  <4> Error -3 while decompressing
  <4> c02a0008(-50008361)->c192d000(4096)
error


Suspecting something.. Now I wanted to be sure ...

I installed Red Hat Limbo 2 via the Red Hat Limbo 1 server with FTP, this
time with less packages selected for install.

This time the same error occured as a couple of hours earlier :

IOError socket error occuring getting
 ftp://<strange chars><10.0.0.3/home/ftp/peterve/pub/RedHat/base/hdlist:
 (-2, 'Name or service not known')


Then I got some suspicions of Limbo 2. Because I needed a working internet
sharing machine again I tried one last thing :

I installed Red Hat Linux 7.3 by FTP via the Limbo 1 FTP server. And PRESTO!
that worked like a charm ...

The P100 is happely sharing the internet again as I type this Bugzilla entry.


My little investigation took a couple of hours and I almost dare to conclude
that there's something terribly wrong with either the net-based installer part
of Limbo 2 or something wrong in general in Limbo 2 which cause malfunction of
the NFS service and FTP service at random times.

Of one thing I'm sure, Limbo 2 is what this issue is concerning less
stable than Limbo 1. Using Limbo 1 I have no / zero / nada problems
regarding NFS/FTP installations.

I really hope that you guys grab this bug and kill it, it looks like
NFS/FTP is very unrealible in Limbo 2.

Comment 5 Need Real Name 2002-08-03 22:48:02 EDT
Just to make add to what these guys are already saying...i tried it on an
inspiron 8100 laptop (client) and shared the files ftp from a suse machine.  I
got the same error that these guys have mentioned earlier.  looks like a string
is off somewhere and it's reading bogus data from memmory.
Comment 6 Jeremy Katz 2002-08-06 18:57:42 EDT
Fixed in CVS
Comment 7 Jay Turner 2002-09-04 09:17:26 EDT
Fix confirmed with re0903.2 tree.

Note You need to log in before you can comment on or make changes to this bug.