Bug 706089 - [abrt] evolution-2.32.2-1.fc14: (SIGABRT) _XAllocID, gdk_cursor_new, e_day_view_init
Summary: [abrt] evolution-2.32.2-1.fc14: (SIGABRT) _XAllocID, gdk_cursor_new, e_day_vi...
Keywords:
Status: CLOSED DUPLICATE of bug 705579
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 14
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1440d1fdf1fba22314d82ce30a2...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-19 13:18 UTC by John Margaritopoulos
Modified: 2012-03-20 14:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-20 14:14:44 UTC


Attachments (Terms of Use)
File: backtrace (51.57 KB, text/plain)
2011-05-19 13:18 UTC, John Margaritopoulos
no flags Details

Description John Margaritopoulos 2011-05-19 13:18:14 UTC
abrt version: 1.1.18
architecture: i686
Attached file: backtrace, 52803 bytes
cmdline: evolution
component: evolution
Attached file: coredump, 124801024 bytes
crash_function: _XAllocID
executable: /usr/bin/evolution
kernel: 2.6.35.13-91.fc14.i686
package: evolution-2.32.2-1.fc14
rating: 4
reason: Process /usr/bin/evolution was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1305044539
uid: 500

How to reproduce
-----
1.
2.
3.
.

Comment 1 John Margaritopoulos 2011-05-19 13:18:17 UTC
Created attachment 499836 [details]
File: backtrace

Comment 2 Milan Crha 2011-05-20 08:08:09 UTC
Thanks for a bug report. I see couple other similar bugs crashing in XAllocID, but none matches this one close enough. I see from the backtrace that this happened in time of opening calendar view for the first time, but somewhere in gdk, when creating a cursor image. If you are able to reproduce this anyhow (though I recall this being rather occasional crash), then giving valgrind a chance to explain what happened with the memory might help to identify the issue. You can run evolution under valgrind like this, but note evolution will be significantly slower due to all memory checking:
   $ G_SLICE=always-malloc valgrind --num-callers=50 evolution &>evo.txt

Then you can examine the evo.txt and check whether it contains anything which will include functions like XAllocID or gdk_cursor_new or e_day_view_init.

Comment 3 abrt-bot 2012-03-20 14:14:44 UTC
Backtrace analysis found this bug to be similar to bug #705579, closing as duplicate. This bug seems to belong to component libX11, libXcursor or libXrender.

Bugs which were found to be similar to this bug: 
  emerald: bug #680592
  gedit: bug #650406
  gnome-scan: bug #609230
  gnome-screensaver: bug #666451
  nautilus: bug #543282, bug #545493, bug #574789, bug #576538, bug #601500, bug #614613, bug #633017, bug #705579
  yelp: bug #587425, bug #618993

This comment is automatically generated.

*** This bug has been marked as a duplicate of bug 705579 ***


Note You need to log in before you can comment on or make changes to this bug.