Bug 70616 - Missing cfdisk utility -- cfdisk, as referenced in fdisk man page, should be updated for inclusion or removed
Missing cfdisk utility -- cfdisk, as referenced in fdisk man page, should be ...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-02 17:17 EDT by Need Real Name
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-20 14:46:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-08-02 17:17:52 EDT
Description of Problem:
The cfdisk utility has been removed and is mentioned in several installation 
guides *AND* books that have been published by Redhat (see below). The utility 
should not have been removed in this fashion without adequate warning.

I can imagine next someone removing the ps utility options, dropping nslookup 
with dig or whatever, and the ls command by list, etc.

Please take care in ensuring backwards compatibility as much as possible - this 
is not the time to be dangerous! At least provide warnings about pending 
removal of utilities and keep them around for a couple of revisions.

Version-Release number of selected component (if applicable):

* Sun Aug 26 2001 Elliot Lee <sopwith@redhat.com> 2.11f-9
  - Don't include cfdisk, since it appears to be an even bigger pile of junk 
than fdisk? :)

How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
http://www.redhat.com/docs/manuals/linux/RHL-7.3-Manual/install-guide/s1-x86-
dualboot-install.html
	
Warning 
  It is highly recommended that you use cfdisk or fdisk to create partitions 
after installing Red Hat Linux. Other partitioning software has been known to 
change the partitioning table of the hard drive and move the Linux partitions. 
If this happens, the boot loader will not be able to find the Linux partitions 
and will not boot into Red Hat Linux.
Comment 1 Elliot Lee 2002-08-02 17:25:11 EDT
Install-guide needs fixing
Comment 2 Sandra Moore 2002-08-05 09:54:14 EDT
The newest revision of the installation guide has been updated to reflect the
removal of the cfdisk utility.

These changes will be available in the next release of the installation guide.

The new Warning note will read as follows:

It is highly recommended that you use parted or fdisk  to create partitions
after installing Red Hat Linux. Other partitioning software has been known to
change the partitioning table of the hard drive and move the Linux partitions.
If this happens, the boot loader will not be able to find the Linux partitions
and will not boot into Red Hat Linux. 


Thanks so much for the feedback.

Best regards,
Sandra

*** This bug has been marked as a duplicate of 68464 ***
Comment 3 Marvin Solomon 2004-07-06 07:11:22 EDT
I'm not sure what the protocol is for reporting this, but bug 68464
has been
marked as closed and it isn't.  See also 70616, which is marked as a
duplicate,
and also closed.

The complaint is that cfdisk is missing even though documentation
recommends
using it.  Several users think that the real fix is to include cfdisk,
but the
official decision is to fix the documentation.  I don't know who's right,
but, I got burned by this on the latest, greatest, for-money version:
 ES3.
According to "man fdisk", in the BUGS section:

   There  are  several  *fdisk programs around.  Each has its problems
and 
   strengths.  Try them in the  order  cfdisk,  fdisk,  sfdisk.   (Indeed,
   cfdisk  is a beautiful program that has strict requirements on the par-
   tition tables it accepts, and produces high quality  partition  tables.
   Use  it  if you can.  fdisk is a buggy program that does fuzzy things -
   usually it happens to produce reasonable results. Its single  advantage
   is  that it has some support for BSD disk labels and other non-DOS par-
   tition tables.  Avoid it if you can.  sfdisk is for hackers only -
 the 
   user  interface is terrible, but it is more correct than fdisk and more
   powerful than both fdisk and cfdisk.  Moreover, it can be  used  nonin-
   teractively.)

I wasted some time trying to find cfdisk before a google search
finally pointed
me to the bugzilla item.

In summary, the "official" position is that fdisk supersedes cfdisk,
but the
documentation for fdisk itself recommends just the opposite.  I'll let you
figure out which is right.
Comment 4 Sandra Moore 2004-07-12 20:24:17 EDT
The current version of the Installation Guide (the Red Hat Enterprise
Linux 3 Installation Guide --
http://www.redhat.com/docs/manuals/enterprise/RHEL-3-Manual/x8664-multi-install-guide/)
does not reference cfdisk. Because our latest version of the
Installation Guide does not include the reference to this utility, we
consider this issue to be resolved.
Comment 5 Sandra Moore 2004-07-21 09:45:27 EDT
Reopening and reassigning this bug -- after receiving email with a
further explaination from Marvin Solomon, this is actually being
reported against the fdisk man page.

From Marvin:
...but the fdisk man page itself URGES you to use cfdisk instead.  Try
"man fdisk".
                                                                     
                    
IMHO, the right fix is to include cfdisk, but if that's deemed not to
be possible, you must expunge mention of cfdisk (or at least advice
urging its use) from ALL the manuals. 


In this case, manuals mean man pages specifically as the Red Hat
Enterprise Linux documentation (the manuals) no longer include
references to cfdisk. Marvin points out that this also hits Red Hat
Enterprise Linux 3.
Comment 6 Eido Inoue 2004-08-20 14:03:09 EDT
the fdisk man page is part of the util-linux pkg, not man-pages proper.
Comment 7 Elliot Lee 2004-08-20 14:46:04 EDT
man page fixed in CVS for future releases.

Note You need to log in before you can comment on or make changes to this bug.