Bug 70646 - Trouble Configuring X with Eizo LCD using DVI Interface
Trouble Configuring X with Eizo LCD using DVI Interface
Status: CLOSED DUPLICATE of bug 67193
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-02 20:35 EDT by Need Real Name
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-02 20:35:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-08-02 20:35:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
I'm having trouble configuring X to run with my display hardware when using the
digital interface. I'm using:

Eizo L565A LCD display (has both analog and digital ports)
Interpeed GeForce2 MX/400 viceo card (DVI-I port, 32Mb RAM)

Thus far I've only been able to make them run in analog mode. When I do that, I
get a nice 1280x1024 resolution, Hsync at 80kHz, Vsync at 75Hz. It works fine,
but I'd like to be able to take advantage of the digital interface. When I try
that, however, nothing works.

According to the manual, the specs for the screen in digital mode are

Hsync 31.5-64kHz
Vsync 60Hz, 70Hz

When I enter these in Xconfigurator's custom mode (the display is not
automatically recognized) and do the test, the display reports a diagnostic
saying that the Vsync is out of spec at 41.6Hz, which is awfully weird.

I tried setting the Vsync paramenter in Xconfigurator to 60 (rather than 60-70),
and got a blank (dark) screen, but no diagnostic.

Since the hardware works together just fine in analog mode, this points to one
or more of:

Digital video processing in the display
Digital video processing in the video card
The DVI-D cable I'm using
X configuration

In fact, I doubt if X even cares whether the connection between the video card
and the screen is digital, but it does seem like some strange interaction
between the X and the card could still have something to do with the problem.
The display allegedly supports DDC, so it seems possible that X is getting
messed up there -- I heard that this sometimes fails.

Unfortunately I don't know much about display systems, so I'm hoping that you
will have some suggestions that will either fix the problem or allow me to
diagnose which component is the culprit.

PS The OS installation is a clean install, out-of-the-box Linux-only workstation
class, brought up to date with all subsequently released patches (except the
2.4.18-5 kernel upgrade).



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Given identical hardware, simply use the digital interfaces and run
Xconfigurator. It should fail on the test. But of course I have no idea if it
reproduces using hardware other than my own.

Additional info:
Comment 1 Mike A. Harris 2002-08-03 13:52:32 EDT

*** This bug has been marked as a duplicate of 67193 ***

Note You need to log in before you can comment on or make changes to this bug.