Bug 70653 - loadlin.exe no longer works with latest 7.3 update
loadlin.exe no longer works with latest 7.3 update
Status: CLOSED DUPLICATE of bug 75311
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-03 00:16 EDT by Patrick Thompson
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Thompson 2002-08-03 00:16:51 EDT
Description of Problem:
After installing 7.3 Linux from the installation CD (kernal: 2.4.18-3),
loadlin.exe booted Linux from DOS just fine. However, after applying the latest
RPMs (kernal: 2.4.18-5), loadlin.exe merely resets the computer while its
loading the kernal.

Version-Release number of selected component (if applicable):
kernal: 2.4.18-5
RAM Disk: 2.4.18-5

How Reproducible:
Always

Steps to Reproduce:
1. Create a folder containing loadlin.exe, initrd-2.4.18-5.img and vmlinuz-2.4.18-5
2. Exit to DOS and navigate to the folder created in step 1 above.
3. Enter the following command:

   LoadLin.exe vmlinuz-2.4.18-5 root=/dev/hda2 ro initrd=initrd-2.4.18-5.img

Actual Results:
System resets.

Expected Results:
Linux boots.

Additional Information:
Comment 1 Trond Eivind Glomsrxd 2002-08-05 12:51:32 EDT
Distutils is a set of Python build utilities, not the sum of all utilities
shipped with the distribution.

Refiling to anaconda, as they are the ones building the CDs and it's the closest
component I can think of :/.
Comment 2 Jeremy Katz 2002-08-05 15:02:23 EDT
This would almost have to be a kernel bug (or change in behavior at least) that
loadlin doesn't work with.
Comment 3 Arjan van de Ven 2002-08-05 15:06:23 EDT
nothing is printed, at all ?
Comment 4 Patrick Thompson 2002-08-05 23:58:41 EDT
arjanv, it begins the load and flashes some text but quickly resets the computer
and begins a reboot.

In reading the documentation in lodlin16.tgz file of the distribution CD, it states:

The loader program works from the DOS prompt or from CONFIG.SYS
under the following conditions:

   1. The buffer memory (lowmem + extended) is great enough
      to hold the compressed kernel image (zImage or bzImage)
      aswell as the initrd image (optional)

   2. A) The CPU is not in virtual-8086 mode
        or
      B) The EMS driver supports VCPI.

My best guess is that vmlinuz-2.4.18-5 kernel exceeds the limit under condition
#1 above. I tried it without using the RAM disk (initrd-2.4.18-5.img) and the
same error occurs, so it looks like its the kernel that's the culprit.
Comment 5 Patrick Thompson 2002-10-22 16:15:38 EDT
loadlin.exe v1.6c, from a slackware ftp site, resolved the >1Mb kernel limitation.

Also verified that it works on RH 8.0
Comment 6 Bill Nottingham 2003-02-07 16:30:47 EST

*** This bug has been marked as a duplicate of 75311 ***
Comment 7 Red Hat Bugzilla 2006-02-21 13:49:21 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.