Bug 70661 - RFE: add "expect" to "Development Tools" section of package selection
RFE: add "expect" to "Development Tools" section of package selection
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: distribution (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-03 10:18 EDT by Kris Urquhart
Modified: 2014-03-16 22:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-29 12:48:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for tcltk.spec that creates separate expectk RPM (2.16 KB, patch)
2002-08-29 12:48 EDT, Kris Urquhart
no flags Details | Diff

  None (edit)
Description Kris Urquhart 2002-08-03 10:18:20 EDT
Description of Problem:
In my experience, expect is used in many development situations, particularly
test targets in makefiles.
Comment 1 Kris Urquhart 2002-08-03 10:23:22 EDT
Unfortunately, the expect package includes expectk, which depends on tk, but
perhaps expectk could be pulled out into its own package?
Comment 2 Bill Nottingham 2002-08-12 15:47:06 EDT
At this point, because of the Tk requirement, we probably won't do this.
Comment 3 Kris Urquhart 2002-08-29 12:47:41 EDT
Please find attached a patch to tcltk.spec that creates a separate expectk RPM,
so the expect RPM no longer depends on Tk or X.
Comment 4 Kris Urquhart 2002-08-29 12:48:44 EDT
Created attachment 73758 [details]
patch for tcltk.spec that creates separate expectk RPM
Comment 5 Bill Nottingham 2002-08-29 14:38:16 EDT
Added as optional (but not default)

Note You need to log in before you can comment on or make changes to this bug.