Bug 70670 - anaconda installer exception during package install.
anaconda installer exception during package install.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-03 13:34 EDT by Christopher B. Lirakis
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-03 13:35:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump file. (65.93 KB, text/plain)
2002-08-03 13:35 EDT, Christopher B. Lirakis
no flags Details

  None (edit)
Description Christopher B. Lirakis 2002-08-03 13:34:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (Windows NT 5.0; U)

Description of problem:
I have tried both  the GUI and text version of the anaconda installer. Both crash at the same point with the same results. The installer does quite a bit. When it gets to 
near 99% done with the package install, it fails with and unhandled exception. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot system from 7.3 CD
2.Choose system, pretty much any configuration. 
3.Allow the installer to operate. 
	

Actual Results:  After the installer gets to 99% of the packages transfered  from the CD to the HD, it crashes. The dump is attached below. I did do 
a media check on the cd's they were ok. 

Expected Results:  I am assuming the installation  should have proceeded. 

Additional info:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 633, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/gui.py", line 353, in run
    self.icw.run (self.runres, configFileData)
  File "/usr/lib/anaconda/gui.py", line 814, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/anaconda/gui.py", line 529, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 135, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 417, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 144, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 209, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 503, in doPreInstall
    id.fsset.write(instPath)
  File "/usr/lib/anaconda/fsset.py", line 784, in write
    f = open (prefix + "/etc/fstab", "w")
IOError: [Errno 2] No such file or directory: '/mnt/sysimage/etc/fstab'
Comment 1 Christopher B. Lirakis 2002-08-03 13:35:54 EDT
Created attachment 68744 [details]
anaconda dump file.
Comment 2 Michael Fulbright 2002-08-05 11:35:42 EDT
Looks like your drive may be failing:

<4>end_request: I/O error, dev 03:00 (hda), sector 5927062
<4>hda: dma_intr: status=0x51 { DriveReady SeekComplete Error }
<4>hda: dma_intr: error=0x40 { UncorrectableError }, LBAsect=5927064, sector=5927064

These are from the error log.

Note You need to log in before you can comment on or make changes to this bug.