Bug 70682 - neat-tui crashes trying to configure Ethernet card
Summary: neat-tui crashes trying to configure Ethernet card
Status: CLOSED DUPLICATE of bug 68769
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-network (Show other bugs)
(Show other bugs)
Version: limbo
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-08-04 00:22 UTC by Marc Deslauriers
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-05 12:10:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marc Deslauriers 2002-08-04 00:22:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
When I select "Ethernet" from the neat-tui menu, it crashes with:

Traceback (most recent call last):
  File "/usr/sbin/neat-tui", line 396, in ?
    mainScreen(screen)
  File "/usr/sbin/neat-tui", line 54, in mainScreen
    nw.runIt()
  File "/usr/sbin/neat-tui", line 167, in runIt
    self.setState(self.eth)
  File "/usr/sbin/neat-tui", line 107, in setState
    if (eth.BootProto and (string.lower(eth.BootProto)=="dhcp") or
(string.lower(eth.BootProto)=="bootp")):
  File "/usr/lib/python2.2/string.py", line 54, in lower
    return s.lower()
AttributeError: 'NoneType' object has no attribute 'lower'


Version-Release number of selected component (if applicable):
redhat-config-network-1.1.12-1

How reproducible:
Always

Steps to Reproduce:
1.Start neat-tui
2.Select "Ethernet"
3.Crashski
	

Actual Results:  crash

Expected Results:  it working!

Additional info:

Here is my ifcfg-eth0 file:

[root@linux network-scripts]# more ifcfg-eth0
DEVICE=eth0
BOOTPROTO=static
BROADCAST=192.168.10.255
IPADDR=192.168.10.200
NETMASK=255.255.255.0
NETWORK=192.168.10.0
ONBOOT=yes
[root@linux network-scripts]#

Comment 1 Warren Togami 2002-08-05 12:10:34 UTC
Duplicate of Bug 68769, current fixed in Rawhide.

Comment 2 Trond Eivind Glomsrxd 2002-08-05 16:42:18 UTC

*** This bug has been marked as a duplicate of 68769 ***


Note You need to log in before you can comment on or make changes to this bug.