This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 706853 - SM Gui “unregister” button deletes “consumer” folder for non network host.
SM Gui “unregister” button deletes “consumer” folder for non network host.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity medium
: rc
: 6.2
Assigned To: Michael Stead
spandey
: Reopened
Depends On:
Blocks: rhsm-rhel62 743047
  Show dependency treegraph
 
Reported: 2011-05-23 05:04 EDT by spandey
Modified: 2015-04-23 19:56 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:14:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
unsubscribe with no network (334.22 KB, image/png)
2011-09-22 15:07 EDT, J.C. Molet
no flags Details

  None (edit)
Description spandey 2011-05-23 05:04:38 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
5/5

Prerequisites :
Client : Rhel5.7 with following subscription manager client 
subscription-manager-firstboot-0.95.5.18-1.git.4.364aa10.el5

subscription-manager-0.95.5.18-1.git.4.364aa10.el5

subscription-manager-gnome-0.95.5.18-1.git.4.364aa10.el5


Steps to Repro : 
Register client to candlepin using subsription-manager gui.
disable client network.
Press unregister button.

Expected Result : 
Proper message should display for network error and client should not unregister.

Actual Result : 
Message displayed on console for network error 
But unregister process deletes consumer folder from “/etc/pki “
Comment 1 Chris Duryee 2011-05-23 10:20:43 EDT
This is working as designed. When a user hits "unregister", a number of steps are performed on the client, similar to "subscription-manager clean". These steps should take place regardless of if the network is available or not.
Comment 2 Chris Duryee 2011-05-24 13:39:38 EDT
We can alter this so that the server call is made first, and if it fails, subsequent client-side operations are not performed.
Comment 4 Michael Stead 2011-09-08 13:23:16 EDT
Was it decided to do what Chris suggests above?
Comment 5 Bryan Kearney 2011-09-08 13:58:56 EDT
Seems to make sense.
Comment 6 Michael Stead 2011-09-20 12:05:02 EDT
Fixed in:

master c83cc36f1605ff767a0c39f404b73c5fe9bfaea3
RHEL6.2 cff579792571a79fc8b66a6b0a545441c8737350
Comment 8 J.C. Molet 2011-09-22 15:07:08 EDT
Created attachment 524460 [details]
unsubscribe with no network

This is working as described in comment 2.  All client data remains intact and the unsubscribe did not happen.

python-rhsm-0.96.12-1.git.0.4862863.el6.noarch
subscription-manager-firstboot-0.96.11-1.git.1.945da16.el6.x86_64
subscription-manager-0.96.11-1.git.1.945da16.el6.x86_64
subscription-manager-gnome-0.96.11-1.git.1.945da16.el6.x86_64


Marking VERIFIED.
Comment 9 errata-xmlrpc 2011-12-06 12:14:25 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.