Bug 70710 - Anacron initscript has wrong error handling when run by unprivileged user
Anacron initscript has wrong error handling when run by unprivileged user
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anacron (Show other bugs)
8.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-04 10:09 EDT by Peter van Egdom
Modified: 2014-03-16 22:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-09 22:54:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter van Egdom 2002-08-04 10:09:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020721

Description of problem:
"anacron start" as a normal user does :

[peterve@limbo-pc init.d]$ ./anacron start
touch: creating `/var/lock/subsys/anacron': Toegang geweigerd OK  ]

[peterve@limbo-pc init.d]$


(ps. toegang gewijgerd is Dutch for permission denied).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. "anacron start" as a normal user
2.
3.
	

Actual Results:  [peterve@limbo-pc init.d]$ ./anacron start
touch: creating `/var/lock/subsys/anacron': Toegang geweigerd OK  ]

[peterve@limbo-pc init.d]$


Expected Results:  [peterve@limbo-pc init.d]$ ./anacron start
touch: creating `/var/lock/subsys/anacron': Toegang geweigerd 
[FAILED]



Additional info:

Source RPM: anacron-2.3-22.src.rpm
Comment 1 Jens Petersen 2002-08-09 04:32:31 EDT
This seems to be a general problem with most of our initscripts...
Not sure what the Right Thing to do here is: should "/etc/init.d/functions"
bail out if the uid is too high, or should the scripts be "chown go-x"ed?
Comment 2 Jens Petersen 2002-08-09 04:40:28 EDT
well "chmod go-x" is not a option obviously, since normal users may want to
check on a service's status, etc.  But perhaps daemon() could be exit politely
if the uid is not appropriate?
Comment 3 Peter van Egdom 2002-10-30 16:35:39 EST
Bug still occurs in Red Hat Linux 8.0
Comment 4 Jens Petersen 2003-07-09 22:54:15 EDT
In anacron-2.3-27 we no longer touch /var/lock/subsys/anacron.
So that should fix this problem.

Note You need to log in before you can comment on or make changes to this bug.