Bug 70718 - random initscript has wrong error handling
random initscript has wrong error handling
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
8.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-04 10:51 EDT by Peter van Egdom
Modified: 2014-03-16 22:29 EDT (History)
1 user (show)

See Also:
Fixed In Version: FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 16:12:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter van Egdom 2002-08-04 10:51:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020721

Description of problem:
[peterve@limbo-pc init.d]$ ./random start
./random: line 21: /dev/urandom: Toegang geweigerd
Initializing random number generator:                      [  OK  ]
chmod: changing permissions of `/var/lib/random-seed': Bewerking niet toegestaan
touch: creating `/var/lock/subsys/random': Toegang geweigerd


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. "random start" as a normal user
2.
3.
	

Actual Results:
./random: line 21: /dev/urandom: Toegang geweigerd
Initializing random number generator:                      [  OK  ]
chmod: changing permissions of `/var/lib/random-seed': Bewerking niet toegestaan
touch: creating `/var/lock/subsys/random': Toegang geweigerd


Expected Results:
./random: line 21: /dev/urandom: Toegang geweigerd
Initializing random number generator:                      [FAILED]
chmod: changing permissions of `/var/lib/random-seed': Bewerking niet toegestaan
touch: creating `/var/lock/subsys/random': Toegang geweigerd


Additional info:

Source RPM: initscripts-6.88-1.src.rpm
Comment 1 Peter van Egdom 2002-11-01 17:23:45 EST
Still occurs in Red Hat Linux 8.0.
Comment 2 Bill Nottingham 2005-09-29 16:12:16 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

Since this script no longer exists, closing.

Note You need to log in before you can comment on or make changes to this bug.