Bug 70802 - Missing DRIVER entries in /usr/share/hwdata/Cards
Missing DRIVER entries in /usr/share/hwdata/Cards
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: hwdata (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-08-05 11:44 EDT by Olivier Baudron
Modified: 2014-03-16 22:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-06 03:36:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Olivier Baudron 2002-08-05 11:44:05 EDT
As I said in bug 66492, when an record in /usr/share/hwdata/Cards has no DRIVER
entry, then Xconfigurator segfaults. These are:

NAME S3 Trio64V2 (generic)
CHIPSET S3 Trio64V2
SERVER S3
#DRIVER s3
NOCLOCKPROBE
#UNSUPPORTED

NAME SiS 300
CHIPSET SiS300
SERVER SVGA
NOCLOCKPROBE

NAME Sun CG8/RasterOps
CHIPSET cgeight
SERVER Sun
 
NAME Sun GS (cgtwelve)
CHIPSET cgtwelve
SERVER Sun24
 
NAME Sun Graphics Tower
CHIPSET gt
SERVER Sun24

NAME Quantum 3D MGXplus with 4M VRAM
CHIPSET mgx
SERVER Sun24
 
NAME Quantum 3D MGXplus
CHIPSET mgx
SERVER Sun24

At least one of them is faulty. In XFree86 (official release), the S3 Trio64V2
is defined has (see xc/programs/Xserver/hw/xfree86/xf86config/Cards):

# S3 Trio64V2

NAME S3 Trio64V2 (generic)
SERVER S3
DRIVER vga
UNSUPPORTED
NOCLOCKPROBE
Comment 1 Mike A. Harris 2002-08-06 04:04:18 EDT
As I said in bug #66492, the Cards file distributed with XFree86 is totally
out of date.  It is not maintained at ALL.  They've considered removing
it entirely last I discussed with them, and they were interested in using
the Red Hat Cards database as it is more up to date.

I'm only saying this so you realize that their Cards database is useless
for comparison.

Since we no longer have a Sparc distribution, and since the remaining
cards listed above are Sun/Sparc entries which are now invalid, I've
removed them as well, as they are not supported AFAIK under 4.x.

If someone who has Sparc machines and has any of the above listed cards
I'm removing (commenting out actually) I will be glad to update the Cards
db for Sparc users if 4.x works with these cards, however I'm unable
to guess what driver works for each (if any) on my own.

The SiS entry is fixed now also (pending and SiS 300 user testing it,
and reporting any bugs).  The S3 one is defaulting to "vesa".  If the
"vesa" driver does not work for a given S3 card, I *MUST* have full
PCI ID data for the specific card in the form:

(Example card is a Radeon:)
01:00.0 Class 0300: 1002:5157
        Subsystem: 1002:013a

It is important I have the numerical ID's here, and the Subsystem or I
cannot special case the specific card.  Changing the default for a whole
widely varying family of cards just for one particular model is a bad
idea.

The above changes will be in rawhide in a day or so.

Note You need to log in before you can comment on or make changes to this bug.