Bug 708201 - OpenJDK RPM should depend on fontconfig
OpenJDK RPM should depend on fontconfig
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: java-1.6.0-openjdk (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: jiri vanek
BaseOS QE - Apps
: Reopened
: 674153 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-26 17:59 EDT by Deepak Bhole
Modified: 2011-12-06 10:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 10:08:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test case (226 bytes, text/plain)
2011-05-26 18:00 EDT, Deepak Bhole
no flags Details
Test case (199 bytes, text/plain)
2011-05-26 18:02 EDT, Deepak Bhole
no flags Details

  None (edit)
Description Deepak Bhole 2011-05-26 17:59:16 EDT
Since fonts cannot be enumerated without fontconfig installed, OpenJDK should depend on fontconfig in both Fedora and RHEL. 

Attached test case will yield an error, "Exception in thread "main" java.lang.Error: Probable fatal error:No fonts found.", on systems with no fontconfig installed.

On systems with fontconfig installed, the program will exit normally.
Comment 1 Deepak Bhole 2011-05-26 18:00:42 EDT
Created attachment 501201 [details]
Test case
Comment 2 Deepak Bhole 2011-05-26 18:02:28 EDT
Created attachment 501202 [details]
Test case
Comment 4 jiri vanek 2011-06-10 05:55:13 EDT
Yap. Since fontconfig  packages  are avaiable for rhel 4-6 and f13-16, there shuld be no problem to add 
"requires fontconfig" to all supporting spec-files.
Comment 6 jiri vanek 2011-06-10 09:05:59 EDT
since no exception from reproducer is considerable as proof that issue is fixed and tested  f14,15, rawhide (NOT TESTED) and Rhel 6
Comment 7 jiri vanek 2011-06-14 05:18:36 EDT
*** Bug 674153 has been marked as a duplicate of this bug. ***
Comment 8 jiri vanek 2011-08-29 03:55:40 EDT
will be included in next release.
Comment 11 errata-xmlrpc 2011-12-06 10:08:56 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1623.html

Note You need to log in before you can comment on or make changes to this bug.