Bug 70834 - The desktop detection problem
The desktop detection problem
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: licq (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-05 18:40 EDT by hjl
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-16 12:08:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hjl 2002-08-05 18:40:16 EDT
licq uses

        elif ps auxwww |grep -q kde\init; then
                FRONTENDS=$FRONTENDS_KDE
        elif ps auxwww |grep -q gnome-\session; then
                FRONTENDS=$FRONTENDS_GNOME
        else

to detect which desktop is running. It is easy to get false postive.
Why not use something like

fuser `which kdeinit` > /dev/null 2>&1
Comment 1 Thomas Woerner 2004-08-16 12:08:27 EDT
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.

Note You need to log in before you can comment on or make changes to this bug.