Bug 708517 - fails to build without downstream patches
fails to build without downstream patches
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tsclient (Show other bugs)
6.1
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Ondrej Holy
Desktop QE
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-27 16:50 EDT by Kamil Dudka
Modified: 2016-07-21 13:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-21 13:01:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
proposed fix (570 bytes, patch)
2011-05-27 16:52 EDT, Kamil Dudka
no flags Details | Diff

  None (edit)
Description Kamil Dudka 2011-05-27 16:50:38 EDT
Version-Release number of selected component (if applicable):
tsclient-2.0.2-6.el6


Steps to Reproduce:
1. rpmbuild --define '__patch /bin/true' --rebuild tsclient-2.0.2-6.el6.src.rpm

  
Actual results:
DEBUG: checking for TSC... configure: error: Package requirements (glib-2.0 gmodule-2.0 gobject-2.0 gtk+-2.0 libglade-2.0 libgnome-2.0 gnome-desktop-2.0 gnom
DEBUG: No package 'libnm_glib' found
DEBUG: Consider adjusting the PKG_CONFIG_PATH environment variable if you
DEBUG: installed software in a non-standard prefix.
DEBUG: Alternatively, you may set the environment variables TSC_CFLAGS
DEBUG: and TSC_LIBS to avoid the need to call pkg-config.
DEBUG: See the pkg-config man page for more details.
DEBUG: RPM build errors:
DEBUG: error: Bad exit status from /var/tmp/rpm-tmp.5JsRtQ (%build)
DEBUG:     Bad exit status from /var/tmp/rpm-tmp.5JsRtQ (%build)


Additional info:
The proposed change is required for Coverity to scan defects in downstream
patches separately.
Comment 1 Kamil Dudka 2011-05-27 16:52:34 EDT
Created attachment 501393 [details]
proposed fix
Comment 3 RHEL Product and Program Management 2011-10-07 12:10:17 EDT
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 6 Mike McCune 2016-03-28 19:14:23 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Note You need to log in before you can comment on or make changes to this bug.