Bug 708528 - fails to build without downstream patches
fails to build without downstream patches
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
6.1
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Chris Leech
Storage QE
: EasyFix, Patch
Depends On:
Blocks: 767187 846704
  Show dependency treegraph
 
Reported: 2011-05-27 17:12 EDT by Kamil Dudka
Modified: 2017-12-06 07:37 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 07:37:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed fix (743 bytes, patch)
2011-05-27 17:13 EDT, Kamil Dudka
no flags Details | Diff
proposed fix V2 (3.26 KB, patch)
2011-05-31 09:31 EDT, Kamil Dudka
no flags Details | Diff

  None (edit)
Description Kamil Dudka 2011-05-27 17:12:56 EDT
Version-Release number of selected component (if applicable):
iscsi-initiator-utils-6.2.0.872-21.el6


Steps to Reproduce:
1. rpmbuild --define '__patch /bin/true' --rebuild iscsi-initiator-utils-6.2.0.872-21.el6.src.rpm

  
Actual results:
DEBUG: /usr/bin/ld: cannot find -lc
DEBUG: collect2: ld returned 1 exit status
DEBUG: make: Leaving directory `/builddir/build/BUILD/open-iscsi-2.0-872-rc4-bnx2i/usr'
DEBUG: make: *** [iscsistart] Error 1
DEBUG: error: Bad exit status from /var/tmp/rpm-tmp.NUW1pm (%build)
DEBUG: RPM build errors:
DEBUG:     Bad exit status from /var/tmp/rpm-tmp.NUW1pm (%build)


Additional info:
The proposed change is required for Coverity to scan defects in downstream
patches separately.
Comment 1 Kamil Dudka 2011-05-27 17:13:44 EDT
Created attachment 501400 [details]
proposed fix
Comment 3 Kamil Dudka 2011-05-31 09:03:47 EDT
Comment on attachment 501400 [details]
proposed fix

I cannot explain why the fix worked when I was testing it, but it did not solve the problem because iscsi-initiator-utils-dont-use-static.patch depends on the iscsi-initiator-utils-sync-iscsi.patch:

DEBUG: Patch #7 (iscsi-initiator-utils-dont-use-static.patch):
DEBUG: + echo 'Patch #7 (iscsi-initiator-utils-dont-use-static.patch):'
DEBUG: + /bin/cat /builddir/build/SOURCES/iscsi-initiator-utils-dont-use-static.patch
DEBUG: + /var/spool/abrt-retrace/coverity/tmp/cov-mockbuild.LTW0Ct/pwrap/patch -s -p1 -b --suffix _RAWBUILD --fuzz=0
DEBUG: /var/spool/abrt-retrace/coverity/tmp/cov-mockbuild.LTW0Ct/pwrap/patch: applying a patch annotated by _RAWBUILD
DEBUG: 1 out of 1 hunk FAILED -- saving rejects to file usr/Makefile.rej
DEBUG: error: Bad exit status from /var/tmp/rpm-tmp.TmEkxz (%prep)
DEBUG: RPM build errors:
DEBUG:     Bad exit status from /var/tmp/rpm-tmp.TmEkxz (%prep)

I will prepare a better fix.
Comment 4 Kamil Dudka 2011-05-31 09:18:49 EDT
Not fully related to this bug, but I noticed that iscsi-initiator-utils-dcb.patch creates a new file ./open-iscsi-2.0-872-rc4-bnx2i/usr/Makefile.orig.  Is that intentionally?
Comment 5 Kamil Dudka 2011-05-31 09:31:48 EDT
Created attachment 501992 [details]
proposed fix V2

The patch should not anyhow affect a regular build.
Comment 6 Mike Christie 2011-06-01 00:30:09 EDT
(In reply to comment #4)
> Not fully related to this bug, but I noticed that
> iscsi-initiator-utils-dcb.patch creates a new file
> ./open-iscsi-2.0-872-rc4-bnx2i/usr/Makefile.orig.  Is that intentionally?

No. A bug. will clean that up.
Comment 7 Mike Christie 2011-06-01 00:31:35 EDT
(In reply to comment #5)
> Created attachment 501992 [details]
> proposed fix V2
> 
> The patch should not anyhow affect a regular build.

Patch looks ok. Will merge it up. Thanks.
Comment 11 RHEL Product and Program Management 2012-05-03 00:47:40 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 12 Jan Kurik 2017-12-06 07:37:58 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.