Bug 70857 - gcc internal error compiling MPlayer-0.90pre6
gcc internal error compiling MPlayer-0.90pre6
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gcc3 (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
http://www2.mplayerhq.hu/MPlayer/rele...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-06 01:47 EDT by Need Real Name
Modified: 2007-04-18 12:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-02 20:17:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pre-processed file (see comment) (669.74 KB, text/plain)
2002-12-06 10:09 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-08-06 01:47:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020805

Description of problem:
In file included from mplayer/mplayer.c:40:
mplayer/mw.h: In function `mplMainDraw':
mplayer/mw.h:215: Internal compiler error in print_rtl_and_abort, at flow.c:6458
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[1]: *** [mplayer/mplayer.o] Error 1
make[1]: Leaving directory `/home/jmd/MPlayer-0.90pre6/Gui'
make: *** [Gui/libgui.a] Error 2

How reproducible:
Always

Steps to Reproduce:
1. ./configure  --enable-gui
2. make
Comment 1 Need Real Name 2002-08-06 01:51:44 EDT
Looks like mplayer calls gcc3 explicitly. Changing component.

The failed command is:

gcc3 -c -O4 -march=i686 -mcpu=i686 -pipe -ffast-math -fomit-frame-pointer
-D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fomit-frame-pointer
-fexpensive-optimizations -fschedule-insns2 -Wall -malign-double -I. -I./event
-I./wm -I./skin -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2
-I/usr/lib/glib/include -I/usr/X11R6/include -I/usr/include/gtk-1.2
-I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -DDEBUG  -o
mplayer/mplayer.o mplayer/mplayer.c

I changed -O4 to -O2 and it compiled OK.
Comment 2 Marek Woszczyna 2002-10-03 06:17:55 EDT
I have the same problem with RedHat 7.3
Comment 3 Need Real Name 2002-12-06 10:03:24 EST
Same here.

gcc3 -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.3 2.96-113)

Comment 4 Need Real Name 2002-12-06 10:09:10 EST
Created attachment 87664 [details]
pre-processed file (see comment)
Comment 5 Need Real Name 2002-12-06 10:10:54 EST
You can not reproduce without installing MPlayer. I attached the pre-processed c
file. You can reproduce with:

gcc3 -c  -O4  -march=athlon -mcpu=athlon -pipe -ffast-math -fomit-frame-pointer
-D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fomit-frame-pointer
-fexpensive-optimizations -fschedule-insns2 -Wall -malign-double -DDEBUG  -o
mw.cpp.o mw.cpp.c


mplayer/mw.c: In function `mplMainDraw':
mplayer/mw.c:191: warning: unused variable `type'
mplayer/mw.c:244: Internal compiler error in print_rtl_and_abort, at flow.c:6458
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
Comment 6 Richard Henderson 2004-10-02 20:17:13 EDT
No ICE with gcc 3.2.

Note You need to log in before you can comment on or make changes to this bug.