Bug 70876 - updated rhn_check crashes always
updated rhn_check crashes always
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
limbo
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-08-06 09:24 EDT by Markku Kolkka
Modified: 2015-01-07 18:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-21 14:19:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb backtrace from the core dump (1.88 KB, text/plain)
2002-08-06 09:29 EDT, Markku Kolkka
no flags Details

  None (edit)
Description Markku Kolkka 2002-08-06 09:24:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020804

Description of problem:
rhn_check from up2date-2.9.33-7.x.9 crashes with segmentation fault when run. 

Version-Release number of selected component (if applicable):
up2date-2.9.33-7.x.9

How reproducible:
Always

Steps to Reproduce:
1.rhn_check -v
2.
3.
	

Actual Results:  # rhn_check -v
/usr/sbin/rhn_check:0: SyntaxWarning: name 'ACTION_VERSION' is assigned to
before global declaration
/usr/sbin/rhn_check:0: SyntaxWarning: name 'Status' is assigned to before global
declaration
creating readOnlyTransaction
handle_action actionid = 5368936, version = 2
Segmentation fault (core dumped)


Expected Results:  rhn_check downloads and installs updates specified in RHN web
interface.

Additional info:

rpm-4.1-0.69, rpm-python-4.1-0.69
Comment 1 Markku Kolkka 2002-08-06 09:29:05 EDT
Created attachment 69085 [details]
gdb backtrace from the core dump
Comment 2 Adrian Likins 2002-08-06 16:08:40 EDT
will take a look
Comment 3 Adrian Likins 2002-08-21 13:49:54 EDT
no idea... looks like a segfault in rpmlib

Can you duplicate this with current up2date/rpm/rpm-python?

I cant seem to duplicate it.
Comment 4 Markku Kolkka 2002-08-21 14:19:10 EDT
up2date-2.9.46-1 in (null) doesn't crash, it only gives a couple of warnings:

# rhn_check -v
/usr/sbin/rhn_check:0: SyntaxWarning: name 'ACTION_VERSION' is assigned to
before global declaration
/usr/sbin/rhn_check:0: SyntaxWarning: name 'Status' is assigned to before global
declaration
Comment 5 Adrian Likins 2002-08-21 19:25:52 EDT
fixed in 2.9.51

Note You need to log in before you can comment on or make changes to this bug.