This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 708797 - 'man crm's examples aren't line-wrapped
'man crm's examples aren't line-wrapped
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pacemaker (Show other bugs)
6.1
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Andrew Beekhof
Cluster QE
: TechPreview
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-29 12:21 EDT by digimer
Modified: 2012-04-03 10:24 EDT (History)
3 users (show)

See Also:
Fixed In Version: pacemaker-1.1.5-7.el6
Doc Type: Technology Preview
Doc Text:
In the previous version of the crm(8) manual page, the EXAMPLES section incorrectly listed several example commands on a single line. This made it particularly difficult for a reader to distinguish these commands. This update introduces a new, completely rewritten manual page, which lists each example command on a separate line.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 11:50:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description digimer 2011-05-29 12:21:54 EDT
Description of problem:

'crm --help' shows the example usages on per line. 'man crm' has them on the same line, which is less easy to read.

crm --help

Examples:

    # crm -f stopapp2.cli
    # crm < stopapp2.cli
    # crm resource stop global_www
    # crm status 

man crm

EXAMPLES
              # crm -f stopapp2.cli # crm < stopapp2.cli # crm resource stop global_www # crm status

Version-Release number of selected component (if applicable):

pacemaker-1.1.5-5.el6.x86_64

How reproducible:

100%

Steps to Reproduce:
1. type 'crm --help'
2. type 'man crm'
3. compare output
  
Actual results:

examples are on the same line.

Expected results:

One example per line.

Additional info:
Comment 2 Dejan Muhamedagic 2011-05-30 10:18:58 EDT
(In reply to comment #0)
> Description of problem:
> 
> 'crm --help' shows the example usages on per line. 'man crm' has them on the
> same line, which is less easy to read.
> 
> crm --help
> 
> Examples:
> 
>     # crm -f stopapp2.cli
>     # crm < stopapp2.cli
>     # crm resource stop global_www
>     # crm status 
> 
> man crm
> 
> EXAMPLES
>               # crm -f stopapp2.cli # crm < stopapp2.cli # crm resource stop
> global_www # crm status

This is an old man page generated from crm --help. The new man page looks entirely different and includes the whole help system. 1.1.6 is going to include the new man page. Andrew, just don't forget to add asciidoc as a build requirement in the spec file.
Comment 3 Andrew Beekhof 2011-05-30 15:44:59 EDT
Excellent.  Will pick it up in the next rebase.
Comment 8 Lon Hohberger 2011-09-28 16:46:56 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Pacemaker continues to be a Technology Preview in Red Hat Enterprise Linux 6.2
Comment 10 Jaromir Hradilek 2011-10-26 05:32:33 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Pacemaker continues to be a Technology Preview in Red Hat Enterprise Linux 6.2+In the previous version of the crm(8) manual page, the EXAMPLES section incorrectly listed several example commands on a single line. This made it particularly difficult for a reader to distinguish these commands. This update introduces a new, completely rewritten manual page, which lists each example command on a separate line.
Comment 12 errata-xmlrpc 2011-12-06 11:50:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1669.html

Note You need to log in before you can comment on or make changes to this bug.