Bug 70910 - Please don't use UTF-8 in po files
Please don't use UTF-8 in po files
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Cormier
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-06 16:04 EDT by Jay Turner
Modified: 2015-01-07 18:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-03 02:05:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2002-08-06 16:04:15 EDT
Description of Problem:
It makes for really ugly installations :-)  Seeing this with the Milan-re0806.0
tree.

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Trond Eivind Glomsrxd 2002-08-06 16:29:03 EDT
Note that this just the po files for anaconda - the reason is the lack of a
utf-8 console for text mode.
Comment 2 Paul Gampe 2002-08-06 22:39:52 EDT
To confirm, I've got this right: 
 
All anaconda .po files should be in native encoding. 
All other .po files should be in UTF-8 encoding. 
 
I assume this does not just apply to CJK, but EMEA languages also? Of CJK we 
only support Japanese for text install.  Chinese and Korean should default to 
English as we don't have a console solution for them.
Comment 3 Jeremy Katz 2002-08-07 10:37:59 EDT
Correct on the anaconda side.  And yes, it applies to all locales
Comment 4 LENHOF 2002-08-09 12:38:21 EDT
lo,

Seems related to this bug...

During installation of limbo 2 I've got a lot of errors (for each package) on VT 1

** (anaconda : 95) : WARNING ** : Invalid UTF 8 string passed to
pango_layout_set_text()

and the description of each package which is printed during installation is
tronqued when there are accentuation

My settings :

more /etc/sysconfig/i18n
LANG="fr_FR.UTF-8"
SUPPORTED="fr_FR.UTF-8:fr_FR:fr"
SYSFONT="LatArCyrHeb-16"
Comment 5 Paul Gampe 2002-08-14 01:27:31 EDT
comps-po and anaconda-po files have been converted to native encoding.  This 
should resolve this problem.
Comment 6 Mike McLean 2002-09-03 16:44:41 EDT
text installs look ok

Note You need to log in before you can comment on or make changes to this bug.