Bug 70914 - agpgart code rebooting computer
agpgart code rebooting computer
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-06 16:41 EDT by Nathan G. Grennan
Modified: 2015-01-04 17:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-01 18:11:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Diff between 2.4.19-final and 2.4.18-7.93 agpgart_be.c (5.93 KB, patch)
2002-08-07 01:35 EDT, Nathan G. Grennan
no flags Details | Diff
Diff between 2.4.19-final and 2.4.18-7.93 arch/i386/kernel/setup.c (11.34 KB, patch)
2002-08-07 01:45 EDT, Nathan G. Grennan
no flags Details | Diff

  None (edit)
Description Nathan G. Grennan 2002-08-06 16:41:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020712

Description of problem:
In kernel-2.4.18-7.92 the VIA agpgart will reboot my computer instantly. It will
do it both compiled in and as a module.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. modprobe agpgart


Actual Results:  Computer reboots

Expected Results:  Computer not to reboot and code to load correctly

Additional info:
Limbo beta2
Athlon 1700+
Abit KT7A-RAID(VIA KT133A chipset)
mem=nopentium
Comment 1 Nathan G. Grennan 2002-08-06 19:01:36 EDT
linux-2.4.19-final works fine with VIA agpgart compiled in.
Comment 2 Nathan G. Grennan 2002-08-06 20:01:58 EDT
linux-2.4.19-final-ac4 works fine with VIA agpgart compiled in.

hehe, now for the odd part

kernel-2.4.18-7.93 i686 works fine with VIA agpgart as a module, but

kernel-2.4.18-7.92 i686 and athlon both reboot on loading VIA agpgart module
Comment 3 Nathan G. Grennan 2002-08-07 01:14:26 EDT
 ok, this has gone from odd to bizarre

kernel-2.4.18-7.93 athlon works fine with VIA agpgart as a module till you
actually use it by startin XFree86

kernel-2.4.18-7.93 athlon with VIA agpgart compiled in reboots as soon as it
loads the agpgart code

kernel-2.4.18-7.93 athlon works fine with VIA agpgart as a module if I remove
mem=nopentium from grub.conf
Comment 4 Nathan G. Grennan 2002-08-07 01:35:45 EDT
Created attachment 69244 [details]
Diff between 2.4.19-final and 2.4.18-7.93 agpgart_be.c
Comment 5 Nathan G. Grennan 2002-08-07 01:38:15 EDT
I checked

drivers/char/agp/agp.h
drivers/char/agp/agpgart_be.c
drivers/char/agp/agpgart_fe.c
include/linux/agpgart.h
include/linux/agp_backend.h


Of those files only agpgart_be.c had any differences between 2.4.19-final and
2.4.18-7.93. I have attached the diff above.
Comment 6 Nathan G. Grennan 2002-08-07 01:44:21 EDT
Below I have attached a diff between 2.4.19-final and 2.4.18-7.93
arch/i386/kernel/setup.c

setup.c contains the setup for the mem=nopentium option
Comment 7 Nathan G. Grennan 2002-08-07 01:45:11 EDT
Created attachment 69245 [details]
Diff between 2.4.19-final and 2.4.18-7.93 arch/i386/kernel/setup.c
Comment 8 Nathan G. Grennan 2002-08-07 01:54:55 EDT
Patch 1490 aka linux-2.4.19-pageattr-rc1-9.patch seems to be responsible for the
agpgart_be.c changes and the point of the patch seems to be a final fix for the
AMD agp bugs which relates to mem=nopentium

This comment in the patch is telling.

/* no more special protections in this 2/4MB area - revert to a
   large page again. */
Comment 9 Dave Jones 2003-08-21 11:48:22 EDT
This should be fixed in current update kernels, right ?

Note You need to log in before you can comment on or make changes to this bug.