Bug 70921 - Konqueror crashes on file:///some/directory
Summary: Konqueror crashes on file:///some/directory
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: athlon Linux
high
high
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-06 21:54 UTC by Landon Curt Noll
Modified: 2015-03-05 01:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-13 08:36:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Konqueror backtrace on file://home (4.80 KB, text/plain)
2002-08-06 21:55 UTC, Landon Curt Noll
no flags Details
Konqueror backtrace on file://tmp (4.80 KB, text/plain)
2002-08-06 21:56 UTC, Landon Curt Noll
no flags Details
Konqueror backtrace on file://localhost/var/tmp (4.80 KB, text/plain)
2002-08-06 21:57 UTC, Landon Curt Noll
no flags Details
konqueror backtrace for file:/// (4.80 KB, text/plain)
2002-08-06 22:03 UTC, Landon Curt Noll
no flags Details
list of RPMs currently installed (16.22 KB, text/plain)
2002-08-08 17:42 UTC, Landon Curt Noll
no flags Details

Description Landon Curt Noll 2002-08-06 21:54:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux; X11; i686; en_US, en)

Description of problem:
When Konqueror is given a URL of a local directory, it crashes
with a SIGABRT.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Access the following URL within konqueror
 file:///home
2.
3.
 

Actual Results:  The application Konqueror crashed with a SIGABRT.

Expected Results:  Konqueror would render the local directory.



Additional info:

I will attach some backtraces.

I am using kdebase-3.0.0-12 with the latest RH7.3 updates.

Comment 1 Landon Curt Noll 2002-08-06 21:55:46 UTC
Created attachment 69185 [details]
Konqueror backtrace on file://home

Comment 2 Landon Curt Noll 2002-08-06 21:56:27 UTC
Created attachment 69186 [details]
Konqueror backtrace on file://tmp

Comment 3 Landon Curt Noll 2002-08-06 21:57:32 UTC
Created attachment 69187 [details]
Konqueror backtrace on file://localhost/var/tmp

Comment 4 Landon Curt Noll 2002-08-06 22:01:02 UTC
 Please note that the text for the 1st attachment should read: 
 
	file:///home 
 
and the text for the 2nd attachment should read: 
 
	file:///tmp

Comment 5 Landon Curt Noll 2002-08-06 22:03:07 UTC
Created attachment 69188 [details]
konqueror backtrace for file:///

Comment 6 Phil Knirsch 2002-08-08 15:23:41 UTC
I've taken a look at it and can't reproduce your problem here, neither on our
7.3 machines with all erratas applied nor on our current rawhide version.

Could you give me a list of the rpms you have installed for

 kernel
 glibc
 kde*

packages?

Thanks,

Read ya, Phil

Comment 7 Bernhard Rosenkraenzer 2002-08-08 15:46:24 UTC
I can't reproduce this either. The backtraces look interesting though (they 
end in the sound system). Did you do anything odd like assigning a file: 
protocol handler to a media player?

Comment 8 Landon Curt Noll 2002-08-08 17:42:56 UTC
Created attachment 69604 [details]
list of RPMs currently installed

Comment 9 Landon Curt Noll 2002-08-08 19:56:07 UTC
> Did you do anything odd like assigning a file:  
> protocol handler to a media player? 
 
No ... I don't even know how to do that so unless something did 
it for me ... 
 
=-= 
 
I do have a number of the KDE Window Manger sound notifications enabled. 
For example. I have New Window "Play Sound" of KDE_Window_Open. 
 
Humm, let me set that off and ... 
 
INTERESTING:  When I do to the Control Center -> Sound -> System Notifications 
-> The KDE Window Manager -> New Window 
 
and unclick 'play sound' the Konqueror no longer crashes. 
 
Does that help? 
 
	

Comment 10 Landon Curt Noll 2002-08-08 19:58:16 UTC
 Here is some additional info on my setup: 
 
Module                  Size  Used by    Not tainted 
nls_iso8859-1           3488   0 (autoclean) 
sr_mod                 15416   0 (autoclean) 
3c59x                  27752   1 
via-rhine              13988   1 
mii                     1812   0 [via-rhine] 
ipchains               37736   9 
ide-scsi                9280   0 
scsi_mod               64608   2 [sr_mod ide-scsi] 
ide-cd                 30016   0 
cdrom                  31200   0 [sr_mod ide-cd] 
cmpci                  27424   2 
soundcore               5668   2 [cmpci] 
pwc                    45344   0 
usb-uhci               24196   0 (unused) 
usbcore                68544   1 [pwc usb-uhci] 
 
I have a Soyo Dragon+ motherboard with a buildin sound system. 
 
My modules.conf says: 
 
# misc devices 
# 
alias parport_lowlevel parport_pc 
 
# networking 
# 
alias eth0 via-rhine 
alias eth1 3c59x 
 
# usb devices 
# 
alias usb-controller usb-uhci 
 
# disable unused video devices 
# 
alias char-major-81-1 off 
alias char-major-81-2 off 
alias char-major-81-3 off 
 
# cmpci and oss sound 
# 
alias snd-card-0 cmpci 
alias snd-card-1 off 
alias sound-slot-0 snd-card-0 
alias sound-slot-1 off 
alias sound-service-0-0 snd-mixer-oss 
alias sound-service-0-1 snd-seq-oss 
alias sound-service-0-2 snd-midi-oss 
alias sound-service-0-3 snd-dsp-oss 
alias sound-service-1-0 off 
alias sound-service-1-1 off 
alias sound-service-1-2 off 
alias sound-service-1-3 off 
alias char-major-116 snd 
options sound dmabuf=1 
options snd snd_major=116 snd_cards_limit=1 snd_device_mode=0666 
snd_device_gid=0 snd_device_uid=0 
 
# pre/post install/remove rules 
# 
pre-remove pwc /sbin/rmmod pwcx-i386 >/dev/null 2>&1 || : 
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 
2>&1 || : 
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 
|| : 


Comment 11 Landon Curt Noll 2002-12-24 04:53:43 UTC
FYI: This bug was fixed with RH8.0. 


Note You need to log in before you can comment on or make changes to this bug.