Bug 70949 - rpm --hash output ugly on narrow terminal
Summary: rpm --hash output ugly on narrow terminal
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-07 08:07 UTC by Jens Petersen
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-07 20:04:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jens Petersen 2002-08-07 08:07:43 UTC
Description of Problem:
On a terminal less than 80 character wide, "rpm ... --hash ..." output is
kinda ugly/broken.  It would be nice if it could handle this case it better.

Version-Release number of selected component (if applicable):
rpm-4.1-0.69

How Reproducible:
every time

Steps to Reproduce:
1. run "rpm -Fvh *" in a narrow terminal

Actual Results:
Output overflows onto the next line for each package.

Expected Results:
Only one line should be used per package.

Additional Information:
I guess rpm is hardcoding the terminal width.  IWBNI it could generate hashes
with total width proportional to the terminal width.

Comment 1 Michael Schwendt 2002-08-07 20:04:22 UTC
I just wanted to file a similar bug, but I have the feeling it might be related
to this one albeit not related to the terminal width. It is the same when I
expand the terminal to full screen width. 

With rpm-4.1-0.69 and the kernel-source I got a progress bar that ends at 97%
with the bash prompt overwriting rpm's last line because rpm didn't seem to
write a line with linefeed to finish its last line of output:

[root@faldor home]# rpm -ivh kernel-source-2.4.18-7.93.i386.rpm
warning: kernel-source-2.4.18-7.93.i386.rpm: Header V3 DSA signature: NOKEY, key
ID 897da07a
Preparing...                ########################################### [100%]
   1:kernel-source          ######### ( 22%)

And at the end:

[root@faldor home]# rpm -ivh kernel-source-2.4.18-7.93.i386.rpm
warning: kernel-source-2.4.18-7.93.i386.rpm: Header V3 DSA signature: NOKEY, key
ID 897da07a
Preparing...                ########################################### [100%]
[root@faldor home]#         ##########################################  ( 97%)

And the cursor one space after the '#'.

Reproducible: Always.


Comment 2 Jeff Johnson 2002-08-07 20:31:02 UTC
IWBNISSMAP. Patches cheerfully accepted, otherwise <shrug>

Comment 3 Michael Schwendt 2002-08-07 20:33:25 UTC
Pardon?

Do you want me to open a separate bug report? Or why does the progress bar stop
at 97%?

Comment 4 Michael Schwendt 2002-08-07 20:44:50 UTC
Well, see bug #71019. Surely a bug.


Note You need to log in before you can comment on or make changes to this bug.