Bug 70965 - gdm 2.4.x upgrade problem, LTSP future concern
gdm 2.4.x upgrade problem, LTSP future concern
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: gdm (Show other bugs)
null
All Linux
low Severity low
: ---
: ---
Assigned To: Havoc Pennington
Mike McLean
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-08-07 07:34 EDT by Warren Togami
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-23 06:00:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2002-08-07 07:34:20 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux) 
 
Description of problem: 
After Limbo2 gdm was upgraded with up2date and after logging out it displayed 
the following message in a dialog box with an OK button. 
 
"The greeter version (2.4.0.4) does not match the daemon version. 
You have probably just upgraded gdm. 
Please restart the gdm daemon or reboot the computer." 
 
Clicking the OK button does nothing.  Even after killing X with 
CTRL-ATL-Backspace it goes straight back to this dialog. 
 
I am a bit concerned about this dialog and its implications for future 
production LTSP installations.  I suspect that after an errata gdm upgrade, 
all new XDMCP sessions will see this dialog with an confusingly wrong (to the 
end-user) message, and be completely unable to login. 
 
Whatever is decided to improve this gdm upgrade dialog, please be careful not 
to kill/restart gdm during package upgrade or when the OK button is pressed, 
because I think this will kill all already-running XDMCP sessions. 
 
Version-Release number of selected component (if applicable): 
Limbo beta 
gdm 2.4.x 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Upgrade gdm 2.4.x 
2. Attempt to click OK. 
3. Think about future LTSP problems after a gdm errata upgrade, especially if 
the upgrade is done without the knowledge of a clueful admin. 
 
Actual Results:   
* OK button does nothing. 
* Completely unable to login. 
* (Confusion) LTSP end-user would be confused by this error message. 
* (Workaround) Restarting gdm would kill all current XDMCP sessions. 
 
Expected Results:   
* OK button should do something, perhaps allow a login. 
* Perhaps change error message to say "Please ask system administrator to 
restart gdm." in order for this message to be less confusing to the LTSP 
end-user. 
* If possible, LTSP should be functional until the admin gets a change to 
cleanly restart gdm.  Each user should be annoyed with this error message 
before login so they are encouraged to bug their admin.
Comment 1 George Lebl 2002-08-07 13:02:49 EDT
Well the package can do a 'soft' restart.  This is what my rpm does.  That is,
restart gdm when all users log out (including remote sessions).  When this
dialog is displayed is when the greeter protocol version does not match the
daemon protocol version.  That is, we can't really login since there are
incompatible changes in the protocol.  This doesn't happen often.  In the gnome2
line of greeters this happened once.  I don't think it will need to happen again
for some time.  Usually it is possible to extend the protocol without making
incompatible changes.

The problem is, we can't use the old greeter since that was already replaced by
the new one by the package upgrade.  And the new greeter wants a new daemon.

If this is on a local (console, non-xdmcp) display there should be buttons such
as "Restart" and "Reboot" as well to allow you to restart gdm or reboot the
computer.

The reason the OK does nothing is that there is nothing to do.  It just ends
your login session (which in most xdmcp setups just makes things jump back)

Perhaps there could be some failsafe mode in this case.  I'm not sure.  Doing a
soft restart on upgrade seems most reasonable.  Changing the message to be more
helpful would also be nice I suppose.
Comment 2 Havoc Pennington 2002-08-07 17:21:20 EDT
How do I do the soft restart in the spec file?
Comment 3 George Lebl 2002-08-07 18:46:00 EDT
See the %post section in the gdm2/gdm.spec.in file on cvs
Comment 4 Elliot Lee 2002-08-26 13:57:58 EDT
Incorporated

Note You need to log in before you can comment on or make changes to this bug.